Trying to instal f.lux via PPA on ubuntu 15.04 but says 404 Not Found



  • Hello,

    I have a ubuntu 15.04.

    I follow the instructions :

    sudo add-apt-repository ppa:kilian/f.lux
    sudo apt-get update
    sudo apt-get install fluxgui

    Then when I hit sudo apt-get update this is the error message I got :

    W: Impossible de récupérer http://ppa.launchpad.net/kilian/f.lux/ubuntu/dists/vivid/main/binary-amd64/Packages 404 Not Found
    W: Impossible de récupérer http://ppa.launchpad.net/kilian/f.lux/ubuntu/dists/vivid/main/binary-i386/Packages 404 Not Found

    Somebody can fix this please ?

    Thanks.

    Dexterneo



  • Same problem there !



  • Well, I am a Linux noob but I managed to hack my way around to making it work.

    The problem is that the app hasn't been updated in a while. The latest seems to be targeting Trusty, which was Ubuntu 14.04. I couldn't figure out how to tell apt to use that old repo, but I did figure out where that info is stored. It's at /etc/apt/sources.list.d/ and there is a file there named kilian-ubuntu-f_lux-vivid.list. Edit that file to say trusty instead of vivid and try to sudo apt-get install fluxgui again. That should do ya!

    Note that there is some funky behavior with flux. Fox example, I could get the "preview" but it would instantly reset to full brightness. I left it along and it finally started working on its own after about 3 or 5 minutes.



  • There is another way by calling xflux daemon directly. You can pass latitude and color temperature to the daemon. Geocoder API calculates Latitude from your IP address. It's working fine for me.



  • I use Ubuntu 14.04, and I was able to install the f.lux for Ubuntu GUI by following @yptrumpet advice. By issuing the following command: sudo gedit /etc/apt/sources.lists.d/kilian-ubuntu-f_lux-utopic.list (apparently different people have different files in this folder, so I suggest to check what is in the folder so that you can correctly target the file you want to edit), I was able to change the repository searched from utopic to trusty, and voilà, the install worked perfectly.



  • Yeah, I've used xflux in the command line (and you can set a startup script -- just add a "command" to startup:
    xflux -l 00:-00 lat and lon
    xflux -l 11:44 uh, what's the setting for the color? I forget, but when you put it in, it works fine, there is just no slow transition.



  • A user in GitHub has a new repository and it works with my Ubuntu 15.10


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.