Dual monitors - f.lux overrides ICC profile on only secondary monitor.



  • Hi,

    I have been having a problem with f.lux ever since trying to use an ICC profile to make the gamma and colors better on my second monitor. I have long used an ICC profile on my primary monitor without issues. Flux does its thing at night-time, but when I disable f.lux (for an hour, until sunrise, etc.) the monitor will return to how it should look as per the ICC profile.

    However, this is not the case with my second monitor. F.lux seems to simply ignore the ICC profile when it is running at all. If I disable f.lux (for an hour, until sunrise, etc.) the monitor appears exactly as if there is no ICC profile. If I exit f.lux completely, and then toggle the ICC profile in Color Management, the ICC profile will become active again. But, as soon as I start up f.lux (at night time for example), the monitor jumps to the non-ICC appearance before starting the 20s transition to night-time lighting. This behavior only happens on my secondary monitor, my primary monitor is fine with its ICC profile and f.lux.

    Settings on both monitors are all setup identically (in nvidia control panel, etc.) with the exception of my primary monitor being 144hz. Each display has one ICC profile, set to default, and "use my settings for this device" checked.

    I've seen a couple of other threads on similar topics (ICC profiles), and the answer as I've read is that f.lux is supposed to respect ICC profiles. So, I'm not sure what's happening here.

    Any help would be appreciated.

    Don't know if any of these details might help:
    Windows 10
    Flux v3.10
    DVI-D connections
    Nvidia GTX 770 (up to date drivers)


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.