Surface Pro 3 Freezes When on Battery Power (not Safe Mode)



  • Re: Surface Pro 3 display still freezes with latest driver

    I have this issue as well. It was happening about once a week, but yesterday, for the first time, it happened three times. I commute with my Surface Pro 3, and it has never frozen when connected to an external docking station--only when I'm on the train. In each incident, Windows has frozen so that I have to long-press the power button to turn it off.

    Surface Pro 3 on battery power using a Type cover
    Windows 8.1 Pro
    Intel HD Graphics 5000 driver 10.18.14.4170 (16 Mar 2015)
    Power mode: Balanced (but "Put computer to sleep" when "Plugged in" is "Never")
    I have probably been running Visual Studio 2015 Professional every time it's locked up.
    I have not had f.lux in Safe Mode.

    It has not locked up when:
    Surface Pro 3 connected to a Surface dock (both types) using an external keyboard
    Running Visual Studio 2015 Professional
    I have not had f.lux in Safe Mode.

    f.lux Settings
    Enabled: Make screen warmer as your backlight dims
    Daytime: 5000K
    At night: 2300K
    Transition speed: Slow

    Possible Solutions
    I'll try disabling Make your screen warmer as backlight dims.
    I'll try using f.lux in Safe Mode.
    It sounds as if it's not worth updating the Intel graphics driver (current version 15.36.31.4414 or 15.33.43.4425).



  • So far, I haven't had any lockups with the Make your screen warmer as backlight dims option disabled. That's not a guarantee that this fixes the issue, but if it doesn't lock up over the next few weeks, I'll be fairly confident then.



  • I saw the original thread too (https://forum.justgetflux.com/topic/45/surface-pro-3-display-still-freezes-with-latest-driver) and I've been having extremely frustrating ridiculous non-responsive black screen on wake issues with both my Pro 3 and my Pro 4. The kind where you lose work you had open in Visual Studio when you walk away and come back and have to hold the power button down for ten seconds. The sleep problem was happening several times a week. It was to the point where I seriously considered disabling sleep.

    Then I saw that, so I uninstalled f.lux and for the last two weeks it has had no sleep issues whatsoever.

    This gem just in from my wife- "I thought the whole point of f.lux was to fix the sleep issues!" :'D Yeah guys, anyway!



  • @jnm236 FWIW, so far, disabling Make your screen warmer as backlight dims seems to have solved my lockup issue.



  • This post is deleted!


  • I don't have enough reputation to flag that as spam, but someone should.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.