screen flickering, monitor going black



  • i love flux and was excited to install it on my new computer (ran it without problems on mac osx 10.6.8) but after a few days i started having intermittent flicking problems. Closing the laptop and opening it helped stop the flickering, but now it's gotten worse. If the monitor goes to sleep, sometimes it won't turn back on and I have to restart the computer. If the monitor doesn't go to sleep, it flickers really badly between what looks like the daytime and nighttime settings for flux.

    updating my graphics driver did not help, nor did another possible solution i saw in this forum about expanding flux's range. i ended up having to uninstall flux but would really like to be able to use it again!

    specs:
    windows 10 64 bit
    intel core i7
    nvidia geforce gtx 950m
    laptop model is asus 501ux

    edited to add - i installed flux at least a week before the windows update on 6/2 but was having the intermittent flickering problem. it got worse after the update



  • @miscellanium O.K. I'm thinking this is a conflict between the Intel and Nvidia graphics cards. If possible, I'd suggest disabling the Intel, as they can be problematic. If you'd like to do the opposite that's fine, but if that's the case, try to find an easy way to re-enable the card again.



  • okay, i disabled the intel but that caused its own problems, so i tried uninstalling and reinstalling the nvidia so i could choose that as the default without disabling anything. so far there seem to be no issues with flux! it'll take a while to be certain but i think this may have solved it. thank you!

    ETA: actually, no, flickering is still there, it waited until i restarted the laptop and was prompted by flux to put in a location. after pausing and restarting flux the flickering seems to have stopped for now, but i'm not sure if this means i need to try disabling intel outright or if a different solution is warranted here.



  • @miscellanium Yeah, disable intel in the BIOS if you're familiar with that. It may be labeled "i-GPU" or "on-board GPU / graphics". How did you disable it first?



  • i disabled the intel driver before. i will try disabling through the bios.



  • @miscellanium Yeah the driver won't stop it.



  • I have the exact same issue on my desktop PC. Furthermore, it 100% reproducible: I search Bing a certain keyword, click images, then click a particular image - voila - the screen goes all black. When I click next image, it returns to a normal state. The issue is also present when in games. For example, I play Red Orchestra, the screen dims when in shadows, or something (inside a dark corner in a building, or under a bush). It's usually scary when I hide - the game is the realistic one - so it's kind of annoying :)

    I beg you to investigate that, because I cannot imagine computer evenings without f.lux.

    Windows 10 x64,
    Intel i5-4670k on Asus Z78-A motherboard,
    AMD Radeon HD 7870 by Asus, HDMI connected to Iiyama ProLite 2377.
    Tried different video drivers, and found that with older drivers (v15.x.x) the issue appears less than on latest (v16.x.x) ones. At least I don't get the black screens by simply browsing a file system)

    (and, yep, I thing I have an integrated video card, but it is never used)



  • @phil_g O.K. do yourself and me a favor, this sounds like the hardware (monitor) is actually dimming when it gets to a dark area.

    Open the "Paint" program and select black. Then get the bucket fill, and click anywhere. Also at the right edge of where the area stops, there is a VERY small square. It will let you expand the page and just drag it out to the very edge before it starts to make scroll bars.

    Then click anywhere on the paint page again. Double click view or tools in the menu at the top. This will hide the big menu and you can get more room.

    A MUCH quicker way to do this is to just zoom it. Hold Windows Key and press + on the number pad. Try to see if the monitor is dimming itself, maybe make the whole screen black with this, and leave it there for 20 seconds.

    Then, hold the Windows key and press D. Windows + D, that is, it will take you to your desktop. You'll quickly be able to see if the screen starts becoming much brighter. If this is the case, then you'll need to turn off something like "X-contrast" or auto contrast / brightness, or maybe even an "eco mode".

    On this note, it's a very good practice to get familiar with quickly increasing and decreasing the brightness of your monitor for day and night time.



  • @Tungsten_smooth you're awesome! There truly was an 'advanced contrast' option, which I've recently enabled for the first time in 5 years. I've tried Paint but it didn't do the trick (my suggestion is because of the white frame around the window). However, when I opened Bing to check my 'favourite' image, the screen instantly blacked out. Got rid of the not-so-advanced contrast option, and the issue disappeared. As a software developer myself, I'm wondering how cool it should've been to find the reason of that contrast-stuff 'bug'.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.