Cursor appears in front of the filter



  • Whenever fl.ux is actively filtering the screen on my new rig, the cursor is not filtered, and appears bright and blue on the tinted screen. Has anyone else experience this and found a solution?
    CPU: AMD FX-6300, Graphics: EVGA Nvdia GeForce GTX 750 Ti



  • Yeah, this is a problem with Windows and there are only 2 ways to fix it. There's only one problem with fixing it: you get an invisible mouse pointer in some video games. Here are the two different methods for fixing this problem (in no special order):

    Method 1: Using Windows Magnifier.

    With this method, you simply open Magnifier and leave it set to 100%, and you leave it open at all times. I think you can even get it to start with Windows somehow, but it can be just as easy to pin it to the Taskbar and then open it every day. After all, it would be a one-click access to it.

    Method 2: Making a very simple change to the Registry.

    In Registry Editor, you just navigate to HKEY_CURRENT_USER\Control Panel\Mouse and change "MouseTrails" to 99. After this, you log out of Windows and log back in. That's all there is to it. This enables Pointer Trails, but you can't see them! :) So, this has the same result as using Windows Magnifier, but without needing to have any extra program open. An obvious problem with this solution is that you would need to set it back to '0' and log out and back in just to undo it if you ever needed to undo it (such as for getting around the invisible pointer problem for some video games).

    I don't recommend simply enabling Pointer Trails directly in the 'Mouse' control panel because I find pointer trails to be extremely annoying. lol

    As of right now, I believe that there's no way to get f.lux to 'color' the pointer. I think it would require a big overhaul of the program and possibly a 2nd process to run next to f.lux.exe. That 2nd process would probably mimic what Magnifier does. Unfortunately, I think that it would have the same problem with invisible pointers in some games.

    In other words, this is just the way it is and this is the only way to fix it.



  • @TwoCables said:

    In Registry Editor, you just navigate to HKEY_CURRENT_USER\Control Panel\Mouse and change "MouseTrails" to 99.

    Per this question in Photo.SE, the more sensible setting appears to be -1. As explained: A buggy setting that seems to enable the cursor trail render but has no actual trails



  • @agent007bond said:

    @TwoCables said:

    In Registry Editor, you just navigate to HKEY_CURRENT_USER\Control Panel\Mouse and change "MouseTrails" to 99.

    Per this question in Photo.SE, the more sensible setting appears to be -1. As explained: A buggy setting that seems to enable the cursor trail render but has no actual trails

    That has the exact same result as '99'. Try it and you will see that it's 100% identical. I just didn't know that '-1' was a possible value; I have only ever been told about '99' for this.

    So no, 99 doesn't result in having visible trails - which I already took the time to explain.



  • @TwoCables It could be that the trails produced by 99 are so far apart that they're completely off-screen. Sure, it looks identical to -1, but I wouldn't be so sure that it is identical. Unless we plug in a screen the size of a stadium, we may never know.

    Anyway, let's not feud over such trivial matters. Whatever works for you :)



  • @agent007bond said:

    @TwoCables It could be that the trails produced by 99 are so far apart that they're completely off-screen. Sure, it looks identical to -1, but I wouldn't be so sure that it is identical. Unless we plug in a screen the size of a stadium, we may never know.

    Anyway, let's not feud over such trivial matters. Whatever works for you :)

    There's no risk of a feud here. I am only making sure to point out that the results are perfectly identical and there's no reason to care about whether you use 99 or -1.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.