f.lux turning off screen



  • So... I love f.lux. But it's recently started turning off my screen after two minutes of inactivity following sunset. This is exceptionally irritating and I can't find a control that would do this. Even disabling the program does not correct for this - the only way to make it stop is to exit f.lux altogether, which is obviously a less than optimal solution. My current OS timeouts are at 5 mins on battery and 15 off, so I'm fairly sure it's not Windows doing it.

    Where would I find the controls responsible for this behavior?

    I'm on a Lenovo Yoga 2 Pro running Win10, 64-bit with fully updated drivers.



  • @Kelgan said:

    So... I love f.lux. But it's recently started turning off my screen after two minutes of inactivity following sunset. This is exceptionally irritating and I can't find a control that would do this. Even disabling the program does not correct for this - the only way to make it stop is to exit f.lux altogether, which is obviously a less than optimal solution. My current OS timeouts are at 5 mins on battery and 15 off, so I'm fairly sure it's not Windows doing it.

    Where would I find the controls responsible for this behavior?

    I'm on a Lenovo Yoga 2 Pro running Win10, 64-bit with fully updated drivers.

    There are no controls responsible for this; it shouldn't be doing it. I don't think it's f.lux doing it because this is absolutely not a part of what f.lux is designed to do. Unfortunately, I personally don't know what the culprit could be.

    How long ago did it start doing this? Did the beginning of its occurrence begin happening after Windows Update ran? Did it begin happening after you made any changes? Can you remember any details concerning when it began happening?



  • It started doing this about two days ago. I'm unsure when Windows update last ran, but Microsoft indicates that the last update for the current release build on Windows 10 was April 12. I have not made any changes to this computer in the last while. Mostly I remember that it started happening at sunset a couple days ago and I haven't been able to make it stop while f.lux is running.

    The only surefire way I've found to stop it is to exit f.lux. As soon as f.lux is restarted, the problem comes right back.

    In answer to your other question, I've got an Intel chipset (it's an ultrabook, so graphics are integrated).



  • @Kelgan said:

    It started doing this about two days ago. I'm unsure when Windows update last ran, but Microsoft indicates that the last update for the current release build on Windows 10 was April 12. I have not made any changes to this computer in the last while. Mostly I remember that it started happening at sunset a couple days ago and I haven't been able to make it stop while f.lux is running.

    The only surefire way I've found to stop it is to exit f.lux. As soon as f.lux is restarted, the problem comes right back.

    In answer to your other question, I've got an Intel chipset (it's an ultrabook, so graphics are integrated).

    NVIDIA and AMD chips can be integrated too.

    Anyway, I guess this will be a bit of a process trying to figure this one out. Personally, I am stumped.



  • It doesn't happen when f.lux is not running? I would ask you to check the Power settings (Turn screen off after x minutes).



  • @agent007bond That is correct, it doesn't happen when f.lux is not running. As I said in my original post, the screen timeout in Power settings is and has been 5 mins on battery and 15 mins when plugged in. That has not changed.


  • f.lux team

    Some questions:

    1. What is your nighttime setting in f.lux? Does it happen if you use a higher kelvin value?
    2. What is the make/model of the monitor?
    3. Are there any controls on the OSD (on-screen display) for the monitor? Can you disable the DDC/CI protocol?


  • @herf

    1. Currently it's set to 3400k for night time; I haven't tested this at higher kelvin values, but that's a good suggestion. I'll check that this evening.

    2. This is a Lenovo Yoga 2 Pro. The monitor is built into the laptop.

    3. Because this is a laptop, those controls do not exist that I'm aware of.



  • I noticed that it's been a few days since I posted anything here...

    If I use a higher kelvin value, I have no problems. I've had it set to 4200K for the past while and not had any issues.



  • @Kelgan Have you expanded the color range? Drag the night slider ALL the way to the left, keep dragging even though it may not move past 3400K. Then click the flashing button that appears. Say yes to both boxes, and reboot. Let us know if your screen turns off at odd times still.



  • It does not seem to be misbehaving at lower K values either, or at least, it is not turning off the screen at two minute intervals.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.