Flux Resets Windows Colour Calibrations



  • When using flux it cancels out my Windows colour calibration and instead reverts it back to standard colour which is greyed out and washed out. Only whenI uninstall flux do I get to use my custom windows colour



  • Is this in Windows 10?



  • Windows 7 64 bit

    all windows happens on 8 too


  • f.lux team

    How are you setting your colors? Did you quit f.lux first? Are you using a hardware calibrator or something in software?



  • Im using the windows software.

    http://i.imgur.com/iXZmZpo.png

    When flux is online and disabled it wont let me change colour profiles. I can temporarily change and the forces it back to flux one after a second. Only when I exit flux can I change my colour profile.

    And then when I restart flux with the colour profile added flux disables my settings and forces default colours which are grey and washed out



  • I can't change profiles either when f.lux is open. However, whatever I do while f.lux isn't open is kept. I mean, when I close f.lux, switch to a different color profile and then open f.lux, that color profile is still selected and being used.

    So, I don't know what's wrong.

    How did you create that profile? I downloaded mine from a professional review site.



  • @lorna said:

    How are you setting your colors? Did you quit f.lux first? Are you using a hardware calibrator or something in software?

    mines from TFT it doiesnt matter I juste deleted flux as if it wont work with my colours then its rubbish isnt it



  • @TrojanH said:

    @lorna said:

    How are you setting your colors? Did you quit f.lux first? Are you using a hardware calibrator or something in software?

    mines from TFT it doiesnt matter I juste deleted flux as if it wont work with my colours then its rubbish isnt it

    Not necessarily, no.

    Have you ever adjusted any of the color-related settings in the Catalyst Control Center?



  • @TwoCables said:

    @TrojanH said:

    @lorna said:

    How are you setting your colors? Did you quit f.lux first? Are you using a hardware calibrator or something in software?

    mines from TFT it doiesnt matter I juste deleted flux as if it wont work with my colours then its rubbish isnt it

    Not necessarily, no.

    Have you ever adjusted any of the color-related settings in the Catalyst Control Center?

    no



  • Huge issue and very annoying since flux's color profile makes all blacks look like grey and completely make the integrity of the colors go by.

    Is there any archived version of the latest 2.x version of flux? I couldn't find one online to use temporarily.



  • My blacks don't look gray.



  • Hey, have you restarted your computer, I've noticed this as well, but currently I'm really not seeing it. I just opend Paint (filled to black) and went to Nvidia.com, and it's nice and dark now. I would sometimes have a reddish (very dark red) tone, but I think that has resolved itself.



  • @Catbodi said:

    Huge issue and very annoying since flux's color profile makes all blacks look like grey and completely make the integrity of the colors go by.

    Is there any archived version of the latest 2.x version of flux? I couldn't find one online to use temporarily.

    Same here. The contrast is now very poor on all my monitors (with settings I didn't change for years) that it's really becoming a strain on the eyes. Unfortunately I deleted the old setup of f.lux I had lying around and I can't find an old version either...



  • I've had this issue with flux on both of my (Windows 7 x64) computers since I installed the program. The "washed out" problem is the gamma being reset.

    To best match the target image in the Windows color calibration wizard, I need to set my gamma to the lowest possible setting. But as soon as I start flux up again, it resets it to the middle of the slider. Or if flux is running, the color (or gamma) will change briefly as I drag the slider, but then it'll revert to the high-gamma color profile a second later.

    BUT I discovered the fix. First, let flux reset your colors, and then turn flux off (or make sure you're in Day mode). Next, go to your graphics control panel (usually accessible via a right-click on the desktop). In my case this was the Intel HD Graphics Control Panel. I also pulled up the built-in Windows calibration tool so I could use their gamma and photo targets. Then (under 'Display' for Intel) I went ahead and used the graphics contol center's color calibration, trying to match the targets set in the built-in calibrator's window.

    I can't believe I didn't try this earlier, but it wasn't until I read this thread and @TwoCables mentioned the Catalyst Control Center that the idea popped into my head. So far it's been working great, and I've simulated the color change by dragging the daytime color slider all the way to the left -- my gamma remained just as I had set it.

    Hope this helps someone else!

    (And hopefully this will stop that irritating gamma flashing that happens as my login screen fades in when I wake my computer up while it's in 'night' mode...)



  • I just upgraded my graphics card from ATI to NVIDIA and got this problem. F.lux resets the gamma and the colors look washed out. It overrides both Windows Color Calibration and NVIDIA Control Panel Color Settings so I can't use them to "blend" the gamma either.

    My system:
    Windows 7 64-bit
    Geforce GTX 960 (driver version 358.50)

    The problem occurs when I start f.lux and persists until I close the f.lux program and reload my color profile. Reloading the color profile while f.lux is on reloads the profile for a second, but then f.lux resets it again.



  • I have AMD Radeon and I'm having exactly the same problem - when I turn the flux on it resets the current settings of calibration/gamma, i've tried changing the calibration using Windows Color Calibration and AMD Radeon Catalyst, but it keeps resetting the settings every time i turn the f.lux on. Can anyone point me to the right direction, how to fix it ? I really got used to the f.lux on my old pc and wouldn't want to delete it...



  • Because of another annoyance of flux (you can't set an install path and it installs itself into your appdata folder instead of somewhere in the programs folder) I just found a very old version in my user files backup. It's so old it doesn't even show it's version anywhere (filedate is 2009), but at least it works. I do not have the setup file, but simply copying over the flux.exe on a recent installation fixed my problems.



  • @miikaah This is Nvidia's fault, and it's been happening for at least 4-5 years now. It's RGB Lmitied in HDMI, and I think even if you use DVI and covert that to HDMI the problem will STILL occur, I don't understand it.

    I have to set my monitor to use RGB limited (16-235) to get around the problem.



  • I figured out this can be fixed via Windows color calibration, but it takes a little effort. Note: I'm on Win7 but I believe this should work for Vista and 10 as well.

    If you go to \Windows\System32\spool\drivers\color there are a bunch of default color configurations. The two you need to worry about are the .icm files. I assume they are named the same for everyone, but mine were named "sRGB Color Space Profile.icm" and "RSWOP.icm" (there many be additional color profiles in there as well from other calibrations. I moved them all to a backup location). Edit: I've since learned these files are for printing, I don't know why moving them worked for me but if you remove them and your print jobs get messed up this could be the cause. These are the files that f.lux reads from as far as I can tell, which is why importing or creating new profiles doesn't work, these are the files that need to be changed.

    I created another folder in that folder, \color\backup, and moved these two files there. Now these are core Windows files so buyer beware (I recommend backing them up instead of deleting them), but as far as I can tell there are no negative effects. In order to do this you have to change the file permissions, they are owned by "TrustedInstaller".

    -Right click -> Properties -> Security -> Advanced -> Owner -> Edit -> set it to yourself.
    -Under the Security tab click Edit, you should now have permissions to change these other permissions. Click on Administrators and give them modify and write access.
    -Apply, you can now move the files safely to the backup location.

    With these profiles gone, f.lux can't read from them anymore. To make sure that f.lux and Windows are using the color profile you want do this:

    -Copy the .icm profile you want to use to this folder, either one you have downloaded or created via Windows color calibration. If you calibrated your monitors earlier there should already be that calibration file in this directory.
    -Right click on the desktop -> Screen Resolution -> Right click on any monitor -> Properties -> Color Management -> Color Management -> Advanced -> Change System Defaults
    -In the Devices tab make sure there are no other profiles click Add -> Browse and find the color profile you moved to the \color directory.
    -Set this profile as default for all monitors (you can have different calibrations for different monitors if you like)
    -Close that window and go to the Devices tab in the other Color Management window and make sure the profile you want is the only one there and is set to default.
    -Close everything out and start f.lux. With only one color profile to read from it selects that and keeps all your settings!


  • f.lux team

    @theheirofgondor this seems to be posted in two threads - my response over here:
    https://justgetflux.com/forum/topic/1111/f-lux-keeps-resetting-windows-color-calibration-amd-radeon-settings/12

    Basically the only profile f.lux cares about at all is the "default" one in the Control Panel -> Colors.

    Messing with CMYK printer profiles probably will only affect your printer.



  • Unfortunately, working on dual monitors, combined with dark winter evenings makes this issue particularly bad. Whilst my work isn't colour sensitive, it's still rather distracting, as can be seen in the link below.

    Monitor Comparison Photo



  • This is driving me crazy. I have created an ICC file, set it as system default and user default. F.Lux ignores it anyway. I can download random profiles from TFT and F.Lux seems to be okay with that. I'm guessing the one generated by Windows is different somehow from the TFT ones. I can tell you it's not permissions related as I can see the file in the file system and apply wide-open permissions and it doesn't work.

    The only thing I need to change is the gamma. If F.Lux just had a default gamma slider, I'd be perfectly happy. But it doesn't.



  • hi @f-lux-team, have we have a clear solution? thank you


  • f.lux team

    This is in the FAQ (just updated):

    https://justgetflux.com/faq.html?q=calibrate+display



  • @kyle_combes : i have try but it does not make any difference. could not calibrate screen in daytime then


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.