Flux can't seem to get location



  • F.lux seems to not be able to get a location. I'm on a Samsung SM-P600 running stock 5.1.1. I have App Ops installed. Judging from that, it looks like f.lux is only requesting "coarse" location, and App Ops says that that is permitted.

    Everything works fine on my Nexus 6 running 6.1 PureNexus.

    I found this topic:https://forum.justgetflux.com/topic/2261/location-trying-to-fing-location-is-not-working-or-what/3. It suggested clearing data and stopping the app has helped some users. Unfortunately, I'm not amongst those.

    Is anyone else having this problem? Has anyone found other solutions or workarounds?

    Thanks!



  • @arthurhjorth Well it's probably obvious but I have no idea--do you have location (Wi-Fi networks location) enabled? Also called Precise location.



  • Haha! Nothing is ever obvious when debugging. But yes, I do have location turned on, with high-precision using both GPS, and WiFi. The "coarse" location is what app ops says that flux has permission for, but I don't seem to be able to change that. FWIW my location setting tells me that flux has made location requests. So at least it's trying. ..

    Edit: I just checked on my Nexus 6 (on which flux works perfectly) and it only needs approximate location there too. So the problem seems to be that it can't get the GPS data despite having access to it.



  • @Tungsten_smooth sorry, didn't hit reply to you when writing the post above. Tagging you now, apologies.


  • Android

    @arthurhjorth well yes, my flux 22.0 on AOSP 4.4.4 Note 2 & Note 3 (2 devices) also has trouble using location although "GPS Test 1.3.2" finds me a 3D-fix after a couple of seconds. I assume developer relies on google location services framework to communicate?
    That'd be a bad msg for aosp ...


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.