"Sorry, we only support 8 and 10-bit displays right now."



  • @tyeth said in "Sorry, we only support 8 and 10-bit displays right now.":

    Standard intel laptop gpu, maybe i965, either way it used to work fine and I can't be the only one....
    Tried to just mash the xflux12 over the top of usr/bin/xflux and got the following (Ubuntu 17.04 upgraded yesterday from 16.04)
    > xflux -l 51.4658 -g -2 -r 0

    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Display 1 has 0 size
    Sorry, we only support 8, 10, 11, and 12-bit displays right now.>

    same issue for me. fedora 26 64bit on Thinkpad t450s with openbox



  • Hello experiencing same issue on Elementary OS running on my laptop.
    Pasted below is output for:

    • lsb_release -au
    • uname -a
    • xflux -z 90210 -r 0
    • lspci -k | grep -A 3 -i "3D"
    • modinfo nouveau

    If there is any other output I can post to help move this issue closer to a resolution or any other suggestions, please let me know.

    ~$ lsb_release -au
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 16.04.3 LTS
    Release:	16.04
    Codename:	xenial
    
    ~$ uname -a
    4.10.0-38-generic
    
    ~$ apt-cache policy fluxgui
    fluxgui:
      Installed: 1.1.11~pre~20170818-g7537228-1~xenial
      Candidate: 1.1.11~pre~20170818-g7537228-1~xenial
      Version table:
     *** 1.1.11~pre~20170818-g7537228-1~xenial 500
            500 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial/main amd64 Packages
            500 http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial/main i386 Packages
            100 /var/lib/dpkg/status
    
    ~$ xflux -z 90210 -r 0
    --------
    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.
    
    Found 1 screen.
    Sorry, we only support 8 and 10-bit displays right now.
    
    ~$ lspci -k | grep -A 3 -i "3D"
    01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 745M] (rev a1)
    	Subsystem: Lenovo GK107M [GeForce GT 745M]
    	Kernel driver in use: nouveau
    	Kernel modules: nvidiafb, nouveau
    
    ~$ modinfo nouveau
    filename:       /lib/modules/4.10.0-38-generic/kernel/drivers/gpu/drm/nouveau/nouveau.ko
    firmware:       nvidia/gp100/gr/sw_method_init.bin
    firmware:       nvidia/gp100/gr/sw_bundle_init.bin
    firmware:       nvidia/gp100/gr/sw_nonctx.bin
    firmware:       nvidia/gp100/gr/sw_ctx.bin
    firmware:       nvidia/gp100/gr/gpccs_sig.bin
    firmware:       nvidia/gp100/gr/gpccs_data.bin
    firmware:       nvidia/gp100/gr/gpccs_inst.bin
    firmware:       nvidia/gp100/gr/gpccs_bl.bin
    firmware:       nvidia/gp100/gr/fecs_sig.bin
    firmware:       nvidia/gp100/gr/fecs_data.bin
    firmware:       nvidia/gp100/gr/fecs_inst.bin
    firmware:       nvidia/gp100/gr/fecs_bl.bin
    firmware:       nvidia/gp100/acr/ucode_unload.bin
    firmware:       nvidia/gp100/acr/ucode_load.bin
    firmware:       nvidia/gp100/acr/bl.bin
    firmware:       nvidia/gm206/gr/sw_method_init.bin
    firmware:       nvidia/gm206/gr/sw_bundle_init.bin
    firmware:       nvidia/gm206/gr/sw_nonctx.bin
    firmware:       nvidia/gm206/gr/sw_ctx.bin
    firmware:       nvidia/gm206/gr/gpccs_sig.bin
    firmware:       nvidia/gm206/gr/gpccs_data.bin
    firmware:       nvidia/gm206/gr/gpccs_inst.bin
    firmware:       nvidia/gm206/gr/gpccs_bl.bin
    firmware:       nvidia/gm206/gr/fecs_sig.bin
    firmware:       nvidia/gm206/gr/fecs_data.bin
    firmware:       nvidia/gm206/gr/fecs_inst.bin
    firmware:       nvidia/gm206/gr/fecs_bl.bin
    firmware:       nvidia/gm206/acr/ucode_unload.bin
    firmware:       nvidia/gm206/acr/ucode_load.bin
    firmware:       nvidia/gm206/acr/bl.bin
    firmware:       nvidia/gm204/gr/sw_method_init.bin
    firmware:       nvidia/gm204/gr/sw_bundle_init.bin
    firmware:       nvidia/gm204/gr/sw_nonctx.bin
    firmware:       nvidia/gm204/gr/sw_ctx.bin
    firmware:       nvidia/gm204/gr/gpccs_sig.bin
    firmware:       nvidia/gm204/gr/gpccs_data.bin
    firmware:       nvidia/gm204/gr/gpccs_inst.bin
    firmware:       nvidia/gm204/gr/gpccs_bl.bin
    firmware:       nvidia/gm204/gr/fecs_sig.bin
    firmware:       nvidia/gm204/gr/fecs_data.bin
    firmware:       nvidia/gm204/gr/fecs_inst.bin
    firmware:       nvidia/gm204/gr/fecs_bl.bin
    firmware:       nvidia/gm204/acr/ucode_unload.bin
    firmware:       nvidia/gm204/acr/ucode_load.bin
    firmware:       nvidia/gm204/acr/bl.bin
    firmware:       nvidia/gm200/gr/sw_method_init.bin
    firmware:       nvidia/gm200/gr/sw_bundle_init.bin
    firmware:       nvidia/gm200/gr/sw_nonctx.bin
    firmware:       nvidia/gm200/gr/sw_ctx.bin
    firmware:       nvidia/gm200/gr/gpccs_sig.bin
    firmware:       nvidia/gm200/gr/gpccs_data.bin
    firmware:       nvidia/gm200/gr/gpccs_inst.bin
    firmware:       nvidia/gm200/gr/gpccs_bl.bin
    firmware:       nvidia/gm200/gr/fecs_sig.bin
    firmware:       nvidia/gm200/gr/fecs_data.bin
    firmware:       nvidia/gm200/gr/fecs_inst.bin
    firmware:       nvidia/gm200/gr/fecs_bl.bin
    firmware:       nvidia/gm200/acr/ucode_unload.bin
    firmware:       nvidia/gm200/acr/ucode_load.bin
    firmware:       nvidia/gm200/acr/bl.bin
    firmware:       nvidia/gm20b/gr/sw_method_init.bin
    firmware:       nvidia/gm20b/gr/sw_bundle_init.bin
    firmware:       nvidia/gm20b/gr/sw_nonctx.bin
    firmware:       nvidia/gm20b/gr/sw_ctx.bin
    firmware:       nvidia/gm20b/gr/gpccs_data.bin
    firmware:       nvidia/gm20b/gr/gpccs_inst.bin
    firmware:       nvidia/gm20b/gr/fecs_sig.bin
    firmware:       nvidia/gm20b/gr/fecs_data.bin
    firmware:       nvidia/gm20b/gr/fecs_inst.bin
    firmware:       nvidia/gm20b/gr/fecs_bl.bin
    firmware:       nvidia/gm20b/acr/ucode_load.bin
    firmware:       nvidia/gm20b/acr/bl.bin
    license:        GPL and additional rights
    description:    nVidia Riva/TNT/GeForce/Quadro/Tesla
    author:         Nouveau Project
    srcversion:     9D2B7DAA1E60592EC2B5465
    alias:          pci:v000012D2d*sv*sd*bc03sc*i*
    alias:          pci:v000010DEd*sv*sd*bc03sc*i*
    depends:        drm,drm_kms_helper,ttm,mxm-wmi,wmi,video,i2c-algo-bit
    intree:         Y
    vermagic:       4.10.0-38-generic SMP mod_unload
    parm:           tv_norm:Default TV norm.
    		Supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J,
    			hd480i, hd480p, hd576i, hd576p, hd720p, hd1080i.
    		Default: PAL
    		*NOTE* Ignored for cards with external TV encoders. (charp)
    parm:           vram_pushbuf:Create DMA push buffers in VRAM (int)
    parm:           nofbaccel:Disable fbcon acceleration (int)
    parm:           mst:Enable DisplayPort multi-stream (default: enabled) (int)
    parm:           atomic:Expose atomic ioctl (default: disabled) (int)
    parm:           tv_disable:Disable TV-out detection (int)
    parm:           ignorelid:Ignore ACPI lid status (int)
    parm:           duallink:Allow dual-link TMDS (default: enabled) (int)
    parm:           hdmimhz:Force a maximum HDMI pixel clock (in MHz) (int)
    parm:           config:option string to pass to driver core (charp)
    parm:           debug:debug string to pass to driver core (charp)
    parm:           noaccel:disable kernel/abi16 acceleration (int)
    parm:           modeset:enable driver (default: auto, 0 = disabled, 1 = enabled, 2 = headless) (int)
    parm:           runpm:disable (0), force enable (1), optimus only default (-1) (int)
    
    


  • xflux12 work for me.

    Linux Mint 17.1 Rebecca (Ubuntu 14.04 trusty)
    Linux-x86_64 AMD FX(tm)-8350 Eight-Core
    NVIDIA Driver Version: 384.90
    Server Version Number: 11.0
    Server Vendor String: The X.Org Foundation
    Server Vendor Version: 1.15.1 (11501000)

    The previous versions don't work with new Nvidia 384.90 driver:

    530654 bytes (2010) version:
    Sorry, we only support 24/32-bit displays right now.
    XF86VidModeGetGammaRampSize returned 2048 entries.

    706004 bytes (2013) version:
    Sorry, we only support 8 and 10-bit displays right now.

    My eyes no longer bleed.



  • @herf Will this patch be released officially? I'd much rather update from repos than have to maintain a manual installation.



  • @magiceye04 untar and run from console.



  • @justen_m Same issue with Intel i3 6th gen, integrated GPU:

    $ ./xflux12 -l 0 -g 0 -r 0 -k 3400 -nofork
    --------
    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.
    
    Found 1 screen.
    Display 1 has 0 size
    Sorry, we only support 8, 10, 11, and 12-bit displays right now.
    


  • OK, on my old system with Ubuntu16.04 Mate and GTX750ti it works now with version12. :)
    On the new system i give it another try because the night mode of Gnome3.24 is not red enough. I hope to find what i had done wrong there.



  • @ntc2ntc2 said in "Sorry, we only support 8 and 10-bit displays right now.":

    @herf Adding -r 0 also works for me. I have two displays and both of them get redshifted. I would like to add -r 0 to xfluxgui [...]

    Hey, I've got it working with xfluxgui by creating a small wrapper script for xflux.

    I´m assuming here that you downloaded xflux11 and saved it on /usr/bin (where the original xflux resides in my Linux Mint).

    Move your original /usr/bin/xflux to /usr/bin/xflux.original

    Save this script as /usr/bin/xflux

    #!/bin/bash
    /usr/bin/xflux11 -r 0 $*

    Now, when you start xfluxgui, it will start the script that, in turn, will start xflux11 and pass all the parameters you have configured in xfluxgui.

    Worked like a charm here.

    Btw, kudos to the author. I've been using f.lux for more than a year now and I sleep much faster/better after working late on my computer.



  • I am working to the the xflux12 version working under Linux Mint 18.3. Found the original xflux, put xflux12 in the same location, then ran it from console so I could see what happened. Went simple and just gave it my zip code, left everything else default. I believe I am running X, don't remember how to tell (it's been a while since I poked my Linux install). I got the following output, which seems to indicate xflux12 thinks it is working, but then something goes wrong. Now what?

    https://pastebin.com/m6TAHuCz



  • @waldyd Same "Display 1 has 0 size" problem for me on Ubuntu 18.04, on an old Thinkpad x230. Tried both of xflux11 and xflux12.