"Sorry, we only support 8 and 10-bit displays right now."



  • Today I updated Nvidia drivers to version 364.12 nad xflux stopped working, saying "Sorry, we only support 8 and 10-bit displays right now." I went through the release notes (http://www.nvidia.com/download/driverResults.aspx/100577/en-us) and found this:

    • Improved X colormap precision from 8 significant bits to 11 on GeForce GPUs. Quadro GPUs already used 11 bits of precision.

    I guess that's the problem. Are there plans to fix this, or will I have to stay with old drivers to use xflux?


  • f.lux team

    11! I guess we will have to patch that :)



  • @herf They turned it up to 11! I'll have to upgrade my drivers, that sounds cool! Nice precise colors!



  • @herf said:

    11! I guess we will have to patch that :)

    Any ETA on that? :)



  • Any updates on 11-bit color support? My eyes are dying here on Arch since the last nvidia update.



  • Made an account just to agree with person above. I'm running arch and flux stopped worked with the same error as OP



  • Until f.lux updates with a fix, I've switched to redshift, more specifically the redshift-gtk-git PKGBUILD from the AUR, and I'd recommend it. In some ways it's even a bit better, for instance it changes based on time of day, so rather than a sudden change at sundown, your screen gradually shifts to red and back over several hours before sundown and after dawn. And the gui app actually works on my system, while fluxgui was a bit unstable.



  • Yeah, me too. My eyes are dying right now at 10pm. Just set up Fedora 24 with the new Nvidia driver and xflux gives me the same error. Can this please be fixed? Thank you.



  • I've been using redshift for now, it does the same thing as f.lux, but is a bit less user-friendly and a bit more customizable.



  • Yeah, thanks for the tip. It's keeping my eyes from roasting, but I'd still like to have f.lux. Would be really nice if they had a Fedora repository too instead of just xflux and the Ubuntu repo with the whole GUI and everything.



  • @herf How's it looking? find the missing bit and patch it, yet ?
    :)



  • @herf Having the same problem here: just got a new laptop with a GeForce GTX 970M using the Nvidia driver and xflux won't work.



  • @f-lux-team Any progress on this? Thanks.



  • I could use a solution for this for Nvidia's proprietary 367.27 drivers. (Nvidia drivers and dependencies from SteamOS repos, rest of the system uses Debian 8 & BunsenLabs repos.)



  • I also registered just to say that we need this patched!

    T.



  • Sorry to bump an old thread but I had the same problem on my Antergos install and this I how I fixed it.

    • Disable lightdm and set gdm as the default DM

    systemctl stop lightdm.service
    systemctl disable lightdm

    systemctl enable gdm
    systemctl start gdm.service

    • Edit /etc/gdm/custom.conf to use Xorg instead of Wayland. Uncomment this line:

    WaylandEnable=false

    • Start xflux

    • Profit, hopefully.

    Note that this worked for me but is probably not the right solution and it might not necessarily work for you.



  • @denniskig said:

    Note that this worked for me but is probably not the right solution and it might not necessarily work for you.

    You said it. This won't work for most people. Are you downgrading your graphics driver with this fix, or is it just a Wayland related bug?



  • The latter



  • @herf Hi herf,

    did you have some time to patch this one after eight months? ;)

    Would be awesome if you fix it and provide new binaries for us (Linux).

    Our eyes are bleeding..



  • Btw. for me the workaround was to downgrade the Nvidia driver to 361.42.



  • May be I repeat, try to use redshift. It analog xflux.



  • @AlexV said in "Sorry, we only support 8 and 10-bit displays right now.":

    May be I repeat, try to use redshift. It analog xflux.

    This is not helpful at all.



  • Is there an ETA on the fix? I've been using redshift for the time being but a recent-ish update made it just not work at all anymore, and I'd really love to not be blinded by my PC late at night.



  • @samkostka

    I actually think there won't be any patch for this.


  • f.lux team

    I have no NVIDIA+Linux machines to test on, but I posted a possible fix here:

    https://justgetflux.com/linux/xflux11.tgz



  • @herf said in "Sorry, we only support 8 and 10-bit displays right now.":

    I have no NVIDIA+Linux machines to test on, but I posted a possible fix here:

    https://justgetflux.com/linux/xflux11.tgz

    Videocard: Nvidia GeForce GTX 650
    Driver version: 367.27
    Command used: xflux11 -l 51.9 -g 4.5 -k 2500
    Terminal output:


    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Your location (lat, long) is 51.9, 4.5

    Your night-time color temperature is 2500
    It's night time. Your screen is changing now.
    Going to background: 'kill 19868' to turn off.

    *** Error in `xflux11': free(): invalid next size (normal): 0x0000000001953950 ***


  • f.lux team

    @Makitk

    Can you get a stack?

    gdb -ex run --args ./xflux11 -z 90210

    Then when it crashes:

    bt



  • @herf

    Output:

    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Your location (lat, long) is 33.8, -118.3

    Your night-time color temperature is 3400
    Going to background: 'kill 24668' to turn off.

    *** Error in `/usr/bin/xflux11': free(): invalid next size (normal): 0x00000000006bb950 ***
    [Inferior 1 (process 24664) exited normally]
    (gdb) bt
    No stack.



  • @herf , I tried single stepping with backtrace after each step (by getting close to the crash and then defining a function that does step; bt as described here: http://stackoverflow.com/questions/1262639/multiple-commands-in-gdb-separated-by-some-sort-of-delimiter).

    Here's the output at the crash (the first stack trace is before the crash; scroll to the end for the similar stack trace at the crash, i.e. at fork.c:152):

    $ gdb --args ./xflux11 -z 97232
    [... set up break points and such, and then single step ...]
    (gdb) 
    145	in ../sysdeps/nptl/fork.c
    #0  __libc_fork () at ../sysdeps/nptl/fork.c:145
    #1  0x0000000000401729 in main ()
    (gdb) 
    *** Error in `/var/tmp/xflux/xflux11': free(): invalid next size (normal): 0x00000000006cc760 ***
    ======= Backtrace: =========
    152	in ../sysdeps/nptl/fork.c
    /lib/x86_64-linux-gnu/libc.so.6(+0x777e5)[0x7ffff68877e5]
    /lib/x86_64-linux-gnu/libc.so.6(+0x7fe0a)[0x7ffff688fe0a]
    /lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7ffff689398c]
    /var/tmp/xflux/xflux11[0x401fba]
    /var/tmp/xflux/xflux11[0x402003]
    /var/tmp/xflux/xflux11[0x402285]
    /var/tmp/xflux/xflux11[0x40130b]
    /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7ffff6830830]
    /var/tmp/xflux/xflux11[0x401799]
    ======= Memory map: ========
    00400000-00404000 r-xp 00000000 103:02 22424545                          /var/tmp/xflux/xflux11
    00604000-006ab000 rw-p 00004000 103:02 22424545                          /var/tmp/xflux/xflux11
    006ab000-006dd000 rw-p 00000000 00:00 0                                  [heap]
    7ffff0000000-7ffff0021000 rw-p 00000000 00:00 0 
    7ffff0021000-7ffff4000000 ---p 00000000 00:00 0 
    7ffff5dd6000-7ffff5ddb000 r-xp 00000000 103:02 8131540                   /usr/lib/x86_64-linux-gnu/libXdmcp.so.6.0.0
    7ffff5ddb000-7ffff5fda000 ---p 00005000 103:02 8131540                   /usr/lib/x86_64-linux-gnu/libXdmcp.so.6.0.0
    7ffff5fda000-7ffff5fdb000 r--p 00004000 103:02 8131540                   /usr/lib/x86_64-linux-gnu/libXdmcp.so.6.0.0
    7ffff5fdb000-7ffff5fdc000 rw-p 00005000 103:02 8131540                   /usr/lib/x86_64-linux-gnu/libXdmcp.so.6.0.0
    7ffff5fdc000-7ffff5fde000 r-xp 00000000 103:02 8131529                   /usr/lib/x86_64-linux-gnu/libXau.so.6.0.0
    7ffff5fde000-7ffff61de000 ---p 00002000 103:02 8131529                   /usr/lib/x86_64-linux-gnu/libXau.so.6.0.0
    7ffff61de000-7ffff61df000 r--p 00002000 103:02 8131529                   /usr/lib/x86_64-linux-gnu/libXau.so.6.0.0
    7ffff61df000-7ffff61e0000 rw-p 00003000 103:02 8131529                   /usr/lib/x86_64-linux-gnu/libXau.so.6.0.0
    7ffff61e0000-7ffff61e9000 r-xp 00000000 103:02 8131562                   /usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0
    7ffff61e9000-7ffff63e8000 ---p 00009000 103:02 8131562                   /usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0
    7ffff63e8000-7ffff63e9000 r--p 00008000 103:02 8131562                   /usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0
    7ffff63e9000-7ffff63ea000 rw-p 00009000 103:02 8131562                   /usr/lib/x86_64-linux-gnu/libXrender.so.1.3.0
    7ffff63ea000-7ffff63ed000 r-xp 00000000 103:02 14292599                  /lib/x86_64-linux-gnu/libdl-2.23.so
    7ffff63ed000-7ffff65ec000 ---p 00003000 103:02 14292599                  /lib/x86_64-linux-gnu/libdl-2.23.so
    7ffff65ec000-7ffff65ed000 r--p 00002000 103:02 14292599                  /lib/x86_64-linux-gnu/libdl-2.23.so
    7ffff65ed000-7ffff65ee000 rw-p 00003000 103:02 14292599                  /lib/x86_64-linux-gnu/libdl-2.23.so
    7ffff65ee000-7ffff660f000 r-xp 00000000 103:02 8132915                   /usr/lib/x86_64-linux-gnu/libxcb.so.1.1.0
    7ffff660f000-7ffff680e000 ---p 00021000 103:02 8132915                   /usr/lib/x86_64-linux-gnu/libxcb.so.1.1.0
    7ffff680e000-7ffff680f000 r--p 00020000 103:02 8132915                   /usr/lib/x86_64-linux-gnu/libxcb.so.1.1.0
    7ffff680f000-7ffff6810000 rw-p 00021000 103:02 8132915                   /usr/lib/x86_64-linux-gnu/libxcb.so.1.1.0
    7ffff6810000-7ffff69cf000 r-xp 00000000 103:02 14292601                  /lib/x86_64-linux-gnu/libc-2.23.so
    7ffff69cf000-7ffff6bcf000 ---p 001bf000 103:02 14292601                  /lib/x86_64-linux-gnu/libc-2.23.so
    7ffff6bcf000-7ffff6bd3000 r--p 001bf000 103:02 14292601                  /lib/x86_64-linux-gnu/libc-2.23.so
    7ffff6bd3000-7ffff6bd5000 rw-p 001c3000 103:02 14292601                  /lib/x86_64-linux-gnu/libc-2.23.so
    7ffff6bd5000-7ffff6bd9000 rw-p 00000000 00:00 0 
    7ffff6bd9000-7ffff6bef000 r-xp 00000000 103:02 14288051                  /lib/x86_64-linux-gnu/libgcc_s.so.1
    7ffff6bef000-7ffff6dee000 ---p 00016000 103:02 14288051                  /lib/x86_64-linux-gnu/libgcc_s.so.1
    7ffff6dee000-7ffff6def000 rw-p 00015000 103:02 14288051                  /lib/x86_64-linux-gnu/libgcc_s.so.1
    7ffff6def000-7ffff6ef7000 r-xp 00000000 103:02 14293159                  /lib/x86_64-linux-gnu/libm-2.23.so
    7ffff6ef7000-7ffff70f6000 ---p 00108000 103:02 14293159                  /lib/x86_64-linux-gnu/libm-2.23.so
    7ffff70f6000-7ffff70f7000 r--p 00107000 103:02 14293159                  /lib/x86_64-linux-gnu/libm-2.23.so
    7ffff70f7000-7ffff70f8000 rw-p 00108000 103:02 14293159                  /lib/x86_64-linux-gnu/libm-2.23.so
    7ffff70f8000-7ffff726a000 r-xp 00000000 103:02 8128720                   /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
    7ffff726a000-7ffff746a000 ---p 00172000 103:02 8128720                   /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
    7ffff746a000-7ffff7474000 r--p 00172000 103:02 8128720                   /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
    7ffff7474000-7ffff7476000 rw-p 0017c000 103:02 8128720                   /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.21
    7ffff7476000-7ffff747a000 rw-p 00000000 00:00 0 
    7ffff747a000-7ffff7484000 r-xp 00000000 103:02 8131560                   /usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0
    7ffff7484000-7ffff7683000 ---p 0000a000 103:02 8131560                   /usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0
    7ffff7683000-7ffff7684000 r--p 00009000 103:02 8131560                   /usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0
    7ffff7684000-7ffff7685000 rw-p 0000a000 103:02 8131560                   /usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0
    7ffff7685000-7ffff77ba000 r-xp 00000000 103:02 8131525                   /usr/lib/x86_64-linux-gnu/libX11.so.6.3.0
    7ffff77ba000-7ffff79ba000 ---p 00135000 103:02 8131525                   /usr/lib/x86_64-linux-gnu/libX11.so.6.3.0
    7ffff79ba000-7ffff79bb000 r--p 00135000 103:02 8131525                   /usr/lib/x86_64-linux-gnu/libX11.so.6.3.0
    7ffff79bb000-7ffff79bf000 rw-p 00136000 103:02 8131525                   /usr/lib/x86_64-linux-gnu/libX11.so.6.3.0
    7ffff79bf000-7ffff79d0000 r-xp 00000000 103:02 8131542                   /usr/lib/x86_64-linux-gnu/libXext.so.6.4.0
    7ffff79d0000-7ffff7bcf000 ---p 00011000 103:02 8131542                   /usr/lib/x86_64-linux-gnu/libXext.so.6.4.0
    7ffff7bcf000-7ffff7bd0000 r--p 00010000 103:02 8131542                   /usr/lib/x86_64-linux-gnu/libXext.so.6.4.0
    7ffff7bd0000-7ffff7bd1000 rw-p 00011000 103:02 8131542                   /usr/lib/x86_64-linux-gnu/libXext.so.6.4.0
    7ffff7bd1000-7ffff7bd6000 r-xp 00000000 103:02 8131578                   /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1.0.0
    7ffff7bd6000-7ffff7dd5000 ---p 00005000 103:02 8131578                   /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1.0.0
    7ffff7dd5000-7ffff7dd6000 r--p 00004000 103:02 8131578                   /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1.0.0
    7ffff7dd6000-7ffff7dd7000 rw-p 00005000 103:02 8131578                   /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1.0.0
    7ffff7dd7000-7ffff7dfd000 r-xp 00000000 103:02 14287358                  /lib/x86_64-linux-gnu/ld-2.23.so
    7ffff7fcf000-7ffff7fd8000 rw-p 00000000 00:00 0 
    7ffff7ff5000-7ffff7ff6000 rw-p 00000000 00:00 0 
    7ffff7ff6000-7ffff7ff8000 rw-p 00000000 00:00 0 
    7ffff7ff8000-7ffff7ffa000 r--p 00000000 00:00 0                          [vvar]
    7ffff7ffa000-7ffff7ffc000 r-xp 00000000 00:00 0                          [vdso]
    7ffff7ffc000-7ffff7ffd000 r--p 00025000 103:02 14287358                  /lib/x86_64-linux-gnu/ld-2.23.so
    7ffff7ffd000-7ffff7ffe000 rw-p 00026000 103:02 14287358                  /lib/x86_64-linux-gnu/ld-2.23.so
    7ffff7ffe000-7ffff7fff000 rw-p 00000000 00:00 0 
    7ffffffdd000-7ffffffff000 rw-p 00000000 00:00 0                          [stack]
    ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
    #0  __libc_fork () at ../sysdeps/nptl/fork.c:152
    #1  0x0000000000401729 in main ()
    (gdb)
    


  • @herf here's what Valgrind says:

    ==25596== Invalid write of size 2
    ==25596== at 0x401DC9: MakeTables(float, unsigned short*, unsigned short*, unsigned short*, int) (in /tmp/xflux11)
    ==25596== by 0x401F9F: SetGammaCRTC(unsigned long, float) (in /tmp/xflux11)
    ==25596== by 0x402002: SetGammaRandr(float) (in /tmp/xflux11)
    ==25596== by 0x402284: SetKelvinAll(float) (in /tmp/xflux11)
    ==25596== by 0x4023E1: Animate(int, int, int, int) (in /tmp/xflux11)
    ==25596== by 0x4012DD: main (in /tmp/xflux11)
    ==25596== Address 0x6e44400 is 0 bytes after a block of size 6,176 alloc'd
    ==25596== at 0x4C2BBAF: malloc (vg_replace_malloc.c:299)
    ==25596== by 0x559687E: XRRAllocGamma (in /usr/lib/x86_64-linux-gnu/libXrandr.so.2.2.0)
    ==25596== by 0x401F7E: SetGammaCRTC(unsigned long, float) (in /tmp/xflux11)
    ==25596== by 0x402002: SetGammaRandr(float) (in /tmp/xflux11)
    ==25596== by 0x402284: SetKelvinAll(float) (in /tmp/xflux11)
    ==25596== by 0x4023E1: Animate(int, int, int, int) (in /tmp/xflux11)
    ==25596== by 0x4012DD: main (in /tmp/xflux11)


  • f.lux team

    @duraid Yow, this must mean that the RANDR call "XRRAllocGamma" is not allocating enough - maybe someone else doesn't know about 11-bit tables...hmm. For this code path you have to ask X to allocate your memory or it doesn't remote properly, I think.

    I will look into it (though hard to do with it no hardware!)

    Can you also try with "-r 0" to turn off this randr mode? It will only work on your primary display.



  • @herf That seemed to do the trick. I only have the one display, but adding -r 0 appears to make things work fine.


  • f.lux team

    ok, so we maybe have a bug in XWindows. That's crazy. Glad -r 0 works!

    I guess we could go back to defaulting to single-display and make you pass a flag for RANDR. But I think there is some secondary reason for RANDR (maybe it remotes better?) that made it the default.



  • Same issue when updating to fedora 25, using the following graphics card:

    Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
    Display Server: Fedora X.org 119 driver:i915 Resolution: 3200x1800@60.02hz
    GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 13.0.2 Direct Rendering: Yes

    $ ./xflux11 -l 6.235925 -g -75.575137 -r 0


    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Sorry, we only support 8 and 10-bit displays right now.

    Any ideas about how to solve this issue?


  • f.lux team



  • The following was prompted:

    $ ./xflux12 -l 6.235925 -g -75.575137 -r 0


    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Display 1 has 0 size
    Sorry, we only support 8, 10, 11, and 12-bit displays right now.


  • f.lux team

    @waldyd interesting so no color table that we can see.
    haswell has some other tricks I haven't tried yet though.



  • @herf Adding -r 0 also works for me. I have two displays and both of them get redshifted. I would like to add -r 0 to xfluxgui if this should work in general with multiple displays, but it sounds like you expect it will not.



  • On Fedora 25, after dnf upgraded xorg-x11-server-Xorg from 1.19.0 to 1.19.1, the problem occurred.
    I have filed a bug for Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=1413444, but I have no idea of whether the problem is the updated xorg or some issues in xflux.



  • Same problem on Arch Linux since update of xorg-server to version 1.19.1.

    Kernel: 4.8.13-1-ARCH x86_64 (64 bit)
    Display Server: X.Org 1.19.1
    GLX Renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2)
    GLX Version: 3.0 Mesa 13.0.3


    $ ./xflux12 -l 51.2 -g 4.5 -r 0

    Welcome to xflux (f.lux for X )
    This will only work if you're running X on console.

    Found 1 screen.
    Display 1 has 0 size
    Sorry, we only support 8, 10, 11, and 12-bit displays right now.



  • herf,
    The flux11 and flux12 binaries you posted fixed the 8/10 bit colour issue for me, however whenever I try to input a latitude greater than 65, it resets to 65. Could you post a quick fix for this? Cheers.



  • @ntc2ntc2 same here for me. -r 0 works on nvidia 367.57 but it would be great if it can be configured for flux gui.



  • Standard intel laptop gpu, maybe i965, either way it used to work fine and I can't be the only one....
    Tried to just mash the xflux12 over the top of usr/bin/xflux and got the following (Ubuntu 17.04 upgraded yesterday from 16.04)
    > xflux -l 51.4658 -g -2 -r 0

    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Display 1 has 0 size
    Sorry, we only support 8, 10, 11, and 12-bit displays right now.>



  • Same issue after updated to Ubuntu 17.04, it was work with 16.10.
    I've tried .11 and .12 binary with and without -r0
    Thinkpad T450s Intel HD 5500



  • The xflux12 binary with the -r 0 option works for me on one Ubuntu 17.04 system, but on another it spouts the same, "Sorry, we only support 8, 10, 11, and 12-bit displays right now." error.

    Works on 17.04 system with NVidia Quadro FX card using NVidia binary driver v340.102.
    Errors on 17.04 system with i3-7100U, using Intel HD graphics 620. No proprietary driver.

    Linux kernel on both is 4.10.0-20, Anybody get xflux12 working using Intel HD 620 graphics on a 7th gen core i[357]-7Xu processor?



  • @herf
    "try https://justgetflux.com/linux/xflux12.tgz"

    Where do i have to put this file?
    I tried usr\local\bin and usr\bin - there were old files named xflux
    I removed them and copied the xflux12 as new xflux
    But it seems not to work. no color change after start of the flux gui
    The nvidia driver version is 375.39



  • I found a solution for my nvidia cards: Gnome 3.24 has a night mode included.
    Only one color temperature, but it works.



  • Typing xflux -r 0 in the terminal gives the result:
    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Usage: xflux [-z zipcode | -l latitude] [-g longitude] [-k colortemp (default 3400)] [-r 1 (use randr)] [-nofork]
    protip: Say where you are (use -z or -l).

    So I got the lat-long coordinates from the Flux indicator applet and put them in with:
    xflux -l -33.8794 -g 151.2193

    This produced:
    Welcome to xflux (f.lux for X)
    This will only work if you're running X on console.

    Found 1 screen.
    Sorry, we only support 8 and 10-bit displays right now.

    Redshift works.

    Downloading, extracting and running xflux12 causes the f.lux indicator applet to appear in the launcher and header bar, but when I click on the applet, no window pops up. I get the same results in the terminal.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.