F.lux prevents screen from sleeping.



  • I experienced this issue before on Windows 8.1, but I didn't realize it was f.lux causing it until I just reproduced the issue on my new Windows 10 box. The issue is that, while f.lux is open (regardless of whether night/day mode), my machine will NOT allow my monitors to go to sleep.

    If I specifically request the screens to sleep, the screens go black, but immediately spring back to being on. If I let my computer sit long enough to put the screens to sleep (I have it set to 5 minutes on my old, 10 minutes on the new), the screens will fade to black like normal, but then will turn themselves back on.

    If I exit f.lux, asking Windows to turn off the displays works correctly immediately, and waiting for them to shut off works fine, too.

    Any idea why this is occurring? If this is happening on both machines, I'd have to think it affects other users, as well. Anyone else run into this?



  • Edit, try "safe mode" in the f.lux menu!

    I've experienced this in the past but it was not because of f.lux. I'm not sure what the issue could be. First try closing all background applications and anything GPU / CPU intensive especially.

    How long has it been since you have updated your drivers? And out of curiosity, what is your sleep time (not for monitors, but for computer) set to? If you want the monitors to sleep so quickly, you may like somewhere around 30-45 minutes to sleep the computers.

    Also, if you use hard disk drives, you may also consider spinning them down with the advanced windows power options after 5-10 minutes as well!



  • I did try safe mode today, and the issue is different, but not gone. Before the setting change, the screen would flick back on immediately after going black (before the monitor even had a chance to complain about no signal). With safe mode enabled, the screen shows the no signal message, stays off for about 20 seconds, then I hear the "device connected" sound and the screens turn back on. It's like Flux is still doing whatever it is that turns the screen back on, just not as often in safe mode.

    Again, this issue goes away altogether if I close Flux.

    My graphics drivers on both machines (GeForce drivers for 640M on the Windows 8.1 machine and Intel HD 6000 drivers for the Windows 10 machine) are both the latest stable versions, and the issue happens nearly identically on both boxes.

    Edit: Also, as far as strenuous background processes, this Windows 10 box is a fresh, clean install. Chrome was the only thing I installed before installing Flux, and the issue started then. All I've really done since then is update drivers and such.


  • f.lux team

    Hmm.Thanks @aejay is this a laptop with multiple external screens? What monitors? Which kind of laptop?



  • Ah, it might seem like a laptop since it's a 640M GPU, but it's actually an All-In-One machine (ET2701INKI, to be exact). That's the machine currently running Windows 8.1. It runs a single built-in monitor. I guess realistically it's a laptop that just can't go anywhere and doesn't have a lid to close :) .

    The new machine is an Intel NUC5i5RYK mini-pc with two monitors—one hooked up by HDMI, the other hooked up by an HDMI-to-DisplayPort cable to the DisplayPort on the box. Both are Asus VS239H-P monitors. That's the machine with Windows 10.

    I also have a Yoga 2 Pro running Windows 10 I haven't tried F.lux on yet. I'll install it on that and see if things work fine there.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.