Darkroom Mode Turns All My Displays RED+Black



  • Is this normal or an issue? When I enable Dark Room (not really sure what its for, just tried it out)
    all my monitors turn Red and Black; and made it impossible to see anything. I had to restart my computer
    to get back to a visual display I could use.

    When in Darkroom Mode I could not click anything, as 95% of the information on the screen was not visible.
    There was a black line which I assume was the top of the taskbar, I could see the parts of the icons in the system tray,
    and fragments of outlines of the icons in the taskbar. Open windows showed bits a pieces, nothing legible though
    page loaded in browser was completely red, no text or images at all.

    Just wondering if this is an issue or what Darkroom Mode is suppose to do?



  • It's supposed to be red and black and the colors are supposed to be inverted, but it's not supposed to make it nearly impossible to see. Either you have some kind of color saturation turned up too high (such as NVIDIA's Digital Vibrance), or you're experiencing some sort of bug.

    Which version of Windows do you have?

    Also, are you using any sort of color saturation setting?



  • @TwoCables

    I am AMD Graphics Cards (2x R9 390x), Windows 8.1, and No color saturation that I know of...
    I've never adjusted any of the color settings in the driver/graphic settings, or in the monitor menus.

    I took a picture with my phone; http://imgur.com/T3DBezQ there are 17 pinned taskbar icons, and 18 system tray icons visible at all times.
    In the phones you can hardly see any; and I did have Chrome open as well, which is not even visible.

    (I reentered the DarkRoom mode to obtain the photo, so photo was not taken the first time I adventured into DarkRoom mode.)



  • Someone else posted this problem somewhat recently. I think they had Windows 8.1 as well, so maybe it's just some kind of a bug with it.



  • I have the same problem. Turning dark room mode on makes most of the text unreadable. I have Windows 8.1 and AMD Radeon R7 360 graphics. Driver version does not seem to be related (tried 15.3 and 16.3).
    But I remember having Dark room mode work correctly earlier. So I suspect that the issue was introduced in some later version of f.lux. Where can I download an earlier version? Preferably the one where dark room mode was introduced, but just a list of version is OK.



  • @Marshall said:

    I've never adjusted any of the color settings in the driver/graphic settings, or in the monitor menus.

    @Veber You all should have a GOOD look through your monitors menu settings. A LOT of the time, they are set to overly bright, very very saturated settings. Sure if you're viewing a game, it may work well, but with drastic color changes it makes f.lux look horrible.

    Please look first in the "Presets" such as "Cinema" "Game" "Movie" and try to find one called "sRGB".

    sRGB is a standard RGB (red green blue) color mode that should look very accurate. Also this should hopefully adjust saturation and also contrast levels.

    Contrast levels are very important. If set too high, the colors look washed out, and too bright--this has nothing to do with the backlight level, referred to as "brightness". It's actually the opposite of the terms for CRT monitors.

    Put Contrast on 50, (or even 40 if it's still distorting colors) and put the saturation right on 50.



  • @Tungsten_smooth thanks for the idea.
    I had contrast at 50 and brightness at 0 (LCD monitor). Changed that to 50/50, 40/50, 40/100, 20/50. Although the change was noticeable, it did not influence the visibility of anything, still had to turn off this mode almost in the blind.



  • BTW, for anyone having the same problem: running a command prompt (win+"R","C","M","D",Enter) really helps to find the controls to disable the dark room mode, as you can see the mouse cursor above it.



  • @Tungsten_smooth

    I have 3 LG Ultrawide 29" Monitors; they only have 4 Picture Mode options; Cinema, Game, Photo, Custom.
    All three monitors are set to Game; which I tried each one to see what would happen.. and the end results are always the same.

    Running Dual AMD R9 390x graphics cards, AMD FX-9590 CPU, 32GB RAM
    If any of that information makes a difference.



  • Either this is AMD's fault, or it's something to do with Windows 8.1 and later. I think i saw someone with Windows 10 having this same problem.



  • @TwoCables I'd rather blame it on Windows ;)



  • @Marshall said:

    @TwoCables I'd rather blame it on Windows ;)

    My reason for saying it could be AMD is, this is now the third time I've seen this problem reported and all 3 times the video card in use was an AMD card.



  • @TwoCables I know... I was just making a joke; a poor one, but still... Blaming Windows is always easier.



  • @Marshall said:

    @TwoCables I know... I was just making a joke; a poor one, but still... Blaming Windows is always easier.

    Oh damn, that's what I initially thought you were doing. lol

    Yeah, it's always more satisfying to blame Microsoft.



  • @Marshall Go to Custom, and set Red Blue and Green to 80 each. Set Saturation to 50%. set Contrast to 50% or lower (as this may sometimes need to be set lower. Brightness is personal preference.



  • @Veber Is contrast at 50 out of 50 (maximum). You said you reduced it, but the way you worded it makes it seem like it's maxed out. Try halving the setting if you haven't already done so.



  • @Tungsten_smooth Sorry for the confusion, I meant "contrast/brightness", just not to write every time "contrast 50 and brightness 50, contrast 40 and brightness 50" etc. Maximum for both of them is 100.



  • What about earlier f.lux versions? Is it possible to install them at all? Because right now it looks like the most likely thing to fix the issue for me (as the dark room mode is not really worth changing OS or graphic board).



  • @Veber I think it's driver related now. I max MAX contrast and RGB levels combined, and use any color preset, movie / game whatever, and it's so dark that I can still see everything. There's no way it's monitor related, but I thank you both for configuring the settings. I think it's some setting in the AMD Catalyst Control Center, and you'll just have to look through the different options.

    @Marshall and Veber, update your drivers, the vendors release drivers about every two months or so!



  • I've been saying it's not the monitor since the first time we saw this issue reported on this forum...

    In case you don't remember, we have already exhausted all of the possible adjustments in the Catalyst Control Center. So, either this is a compatibility problem between Windows 8/8.1 (and Windows 10) and f.lux, or it's a problem with AMD's GPUs. We have not seen anyone reporting this problem in Windows 7 or with NVIDIA's GPUs.



  • @TwoCables Oh yeah, I remember getting pictures of the control center! Actually, I think we did that more than once! Well damn, yeah this is odd.



  • @Tungsten_smooth said:

    @TwoCables Oh yeah, I remember getting pictures of the control center! Actually, I think we did that more than once! Well damn, yeah this is odd.

    Yeah, we did it at least 2 or 3 other times, and each time we failed at fixing it and in the end, the person realized that they just couldn't use Darkroom Mode. The same is true here: Darkroom Mode simply isn't an option for you guys.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.