f.lux doesn't seem to work any longer



  • When I first used f.lux, over a year ago, it was noticiable when it kicked on. Now I'm not seeing any difference on either computer I use it with. The only change I've made was to switch from Windows 2000 to WinXP.

    When I try the 24 hour preview, and the sun moves around the sine wave, there is no change at any point. This confirms that it isn't working. Is there anything I can do to fix this problem?

    John



  • I just noticed that the setting at night is set to "halogen". I never would have made this choice so an automatic upgrade must have. I've turned off automatic upgrades and I want to use a setting where NO blue light will get through, if that's possible. Which setting is best for this?

    John



  • I've changed the settings to Candlelight, rebooted, but still don't see any difference when I run the 24 hour preview. There must be something in WinXP that is overriding f.lux. Any suggestions how I can fix this?

    John


  • f.lux team

    Sounds like an upgrade to your video driver might help. The setting at night is halogen by default on first install for everyone, you have to unlock warmer temperatures with a restart.



  • Yeah, the display driver that your computer is using might be the generic Microsoft driver.



  • My graphics card on this computer is an ATI Radeon 9800 Pro, and i have the ATI driver installed.

    Perhaps I should uninstall this version and go back to an early version that works and doesn't make the assumption that all people use f.lux for the "halogen" light it provides.

    Is there a way to download an earlier version?



  • I'm not finding anywhere on AMD's site for downloading older versions. So, you'd have to search the internet for a third-party download of the version that you want while also making sure that the version you find is compatible with Windows XP (and be sure it's compatible with XP 32-bit or 64-bit, whichever you have).

    However, a possible cause of this problem might be some kind of setting in the Catalyst Control Center that isn't allowing other programs to set the color. In the NVIDIA driver, this setting is overridden by f.lux somehow, but the AMD driver might be different because AMD's cards seem to be more focused on things like color and image quality while NVIDIA's GPUs seem to be more focused on raw gaming performance, putting color and image quality secondary to that.

    I don't know the Catalyst Control Center, so you'd have to look around in it.



  • Halogen has ALWAYS been the default -- it's already quite a change for most people, and lots of people even think 4700K is a big change, but it just takes an adjustment.



  • You were right, the problem was driver related. It was hard to find a newer driver for the AMD Radoen 9800 Pro, and installing a newer Catalyst Control Center didn't do it (it never seems to install)...but I finally was able to go from v6.1 driver to v8.1 driver and that did the trick.

    About the Halogen setting being default...I just assumed that people were using f.lux for sleeping problems, and wanted a setting that would have no blue light. I'd guess Halogen has plenty of blue light, but please tell me if I'm wrong on that. And are the lower settings, 3400 and 2700, completely devoid of blue light? I'd like to know that for sure because I also have blue blocking glasses that I could use at the computer if necessary.

    Thanks for the help...



  • If you don't want any blue light coming from your monitor, then you will need to do the following:

    1. In your monitor's settings, see if you can remove all blue and green. The only color you want it showing is red. This will make a small difference, but it will help.
    2. Using your monitor's onboard controls again, lower its brightness all the way, or just 10 or 20% to start with until your eyes adjust.
    3. Choose 1200K from the "Lighting at night" submenu.
    4. Press Alt+Page Down 6 times, or just press and hold Alt+Page Down until f.lux dims all the way. On my computer, this makes everythig more black and it also warms the color up a hair more, to 1126K.

    .
    If you were to change your indoor lighting to be pure red light, then you would see that even THIS isn't perfectly red. I am speaking from experience because when I'm getting ready for bed, I switch to pure red light (red FEIT brand LED lights) and I'm ALWAYS still using my computer at this point. So what I do is I change to 1200K, press Alt+Page Down just once (any more is too dim for me), and I change my monitor's settings to have no blue and green and I also dim its brightness all the way. Even after this, I still wish it could be redder. My lights are very red. :)

    It's critical to also lower your monitor's backlight (lower its brightness) because otherwise you will still have an alerting quality of light, even if it could be read by a spectrometer as being pure red.


  • f.lux team

    @jbclem check out http://fluxometer.com/rainbow - we are in the midst of a huge project to measure and understand the effects of all lights, screens, and filters on the body and on sleep. Play around with it for a bit and see what you find (you can turn f.lux on and off by device and also see common glasses and filters).


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.