f.lux automatically disabling when I launch a videogame?



  • Hi all,

    I've noticed that when I launch a videogame, f.lux is disabling itself. Also, when I close the videogame, it isn't returning to my screen set night time temperatures unless I open up the dialog and run a 24-hour preview to cycle it through blue and back into orange.

    Has anyone else noticed this? It wasn't covered in the FAQs and I can't see any videogame-related posts on here.

    As for specifics, I'm running Windows 10 Pro 64-bit on a pretty old AMD Athlon II processor and a NVIDIA GeForce GTX 550 Ti. I do have NVIDIA's "GeForce Experience" software installed on my PC, if that affects anything.

    Cheers,
    Dean

    (also, as an aside, might anyone know why I wasn't allowed to use my primary email address to sign up here? It's an outlook.com one)



  • @deansmith Does it make a difference if you launch in windowed mode? I have problems when I use fullscreen on Windows 10, I've grown use to closing f.lux when I play games due to latency issues.



  • @Crosam I'll have to install another game and try running that in windowed mode, as the game I want to play is incapable of it! Tried forcing it in the launch options, but to no avail.



  • @Crosam Gave it a go with a few different games and didn't see any problems! Also, I ran the same videogame on my Surface Pro 3 and that didn't give me the issue. I guess it's an issue with that particular game (it is 13 years old...). I am still unable to launch it in windowed mode, but can try downloading a third-party wrapper to do that for me, if it helps diagnose the problem.



  • Another thing it might be important to note is that f.lux still tells me that my current lighting is 3000 K (my night setting), in spite of the fact that the screen has turned blue again.

    Just tried tricking it by minimising my game and running a 24 hour cycle to reset the temperature to night setting, but it unfortunately jumps back to day temperature as soon as I select the game again.



  • One more thing, I did figure out how to make my game run in a window, and it does still automatically revert my screen temperature to daylight! I can run a cycle to set it back to night setting, but as soon as I switch back to the game it reverts.

    However, the videogame does not override movie mode, so I can use that for now :)

    Hope this is all useful to someone!


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.