f.lux causes monitor to skip or pause every second like the tick of a clock.


  • Android

    Having a pretty serious issue with using f.lux on my Windows 10 desktop and my Windows 10 laptop. About every second at the exact same interval, like the tick of a clock, the display would skip for a split second. It it very notifiable when anything smooth is scrolling or I am slowly dragging a window around. It happens worse on my laptop than it does on my desktop. Because of this issue, I cannot use it on my laptop and it causes some issues on my desktop if I am watching videos or playing games.



  • @ExiledLie what video hardware are you using? Go to device manager and display adapters.


  • Android

    I forgot to mention that this happens when ever the application is running, not just during the transition period. I also do not notice this at all on my Windows 7 desktop. I do not notice any additional issues during the transition period.

    My Windows 10 desktop is running a GTX 970. The Windows 10 laptop is running an i5 with integrated graphics ( not sure of the exact model off the top of my head). And the Windows 7 desktop is running a GTX 260.

    Right now I think this might be an isue with Windows 10 issue. The Windows 10 deaktop is running a clean OS install and the laptop is upgraded from 8.1.

    When I get some more time I will check if there are other similarities, such as applications, between the laptop and desktop that might be causing the issue that isn't being seen on the Windows 7 deaktop.

    P.S. I would call the issue microstutter on each tick of a second.



  • @ExiledLie Yeah, I'd say for now it's something you've got on Windows 10. Can you list out any programs you may think be at fault? I good way to do this is just go to the control panel and look at the programs listed there, you may find something interesting.


  • Android

    Applications that are on both my Windows 10 laptop and desktop that are not on my Windows 7 desktop:

    Windows 10 Built in Apps
    One Drive
    Kaspersky Internet Security (This is installed on my Windows 7 Desktop as well but the windows 10 version could be acting differently)
    FireFox
    Chrome
    Intel Video Drivers (The Windows 7 Desktop runs AMD without integrated video. The windows 10 desktop does not use the integrated video adapter but has the drivers installed)
    Steam

    The two things that sound likely are Kaspersky and the Intel Video Drivers. Both Windows 10 computers are use the 4th Generation Intel Haswell Processors.

    I can test this on a 4th computer I have which has an older Intel CPU and is also running Windows 10. I can also test it on my brothers older AMD desktop that is also on 10.

    One other thing I might want to mention. The laptop I have has a touch screen and an active digitizer. I am not sure if that might cause issues with the f.lux software.



  • @ExiledLie I'd say remove the intel drivers and let us know what happens.


  • f.lux team

    You can try "safe mode" if you want to solve this - it turns off polling, but can leave your screen tinted if anything goes wrong.

    Generally this is due to bad drivers, but Windows 10 drivers are still a little rough compared to Win7.


  • Android

    @Tungsten_smooth I found out that the Intel drivers are disabled on my desktop, so that inst what is causing it on the desktop.



  • @ExiledLie Hmm, could you try enabling them, just for laughs?



  • I can confirm this is coming from flux.
    My system is Win7 64 bits, Haswell 4720HQ with HD4600 igpu and an Nvidia 965M dgpu with 4264 and 4332 (latest) Intel drivers, 361.43 (also happened on older ones) Nvidia drivers.
    I was very annoyed to have such stutter on this powerful hardware so i decided to investigate.

    Spoiler: Disabled the one "global video thing" i didn't test, aka flux and magic ! Everything is smooth again, no more stutter !
    I can also confirm that the SAFE MODE option doesn't produce the stutter. It could use a more explicit name or a popup though.

    For the actual investigation:
    I first noticed this in Warframe, video of its consequences on the cloth physics simulation + vsync: http://gfycat.com/TornFrailBarnowl
    The physics simulation seems quite sensible to the frame time. You can see that the frame time go slightly above 16.67ms every sec. This was with Vsync ON, so all the 17+ms frames miss the vsync interval and then have to wait the next one in 16.67ms (classical 60 -> 30 vsync fps drop). I had to turn vsync off to avoid this 30fps drop from those longer frames...

    Then I actually started to notice this in Firefox, scrolling a text-heavy page showed exactly the same symptom, perfectly smooth except there's a stutter every second.
    It was very noticeable on this video that can be used as a smoothtest: https://www.youtube.com/watch?v=5xkNy9gfKOg

    Finally while profiling an OpenCL pathtracer i'm working in Intel Vtune, i found out that i could literally see the drop in gpu usage.

    Album with screenshots of the profiling visualisation of flux: http://imgur.com/ceorcdv&JFV0pEE&qkBpmQc&4eJrshJ&EeEAO78
    On screenshot 1, I was profiling my pathtracer, you can clearly see that the gpu simply goes idle for a ~16ms.
    On screenshot 5, then I attached the profiler to the flux.exe process and profiled it for 5 seconds.
    On screenshot 2, zoomed on one of groups of 2 flux packets. Time window is ~20 milliseconds.
    On screenshot 3, zoomed on the first group of flux packet. Time window of of ~160 microseconds
    On screenshot 4, zoomed on the second group of flux packet. Time window of of ~400 microseconds

    I can see you're using 2 threads, each one submitting a different group of packets, only one with a present packet...
    I just read the faq and found this part:
    "What does Safe Mode do on Windows?
    [...] It disables all polling we normally do to ensure that we're the active color profile. [...]"
    I'm wondering why this task need to submit commands to the gpu. Are you re-applying the color-profile without actually checking if it has changed ? Or is this needed to actually detect a color profile change ?

    PS: Sry for poor writing, it's late and i'm not native english speaker :p



  • Just registered to confirm this issue.

    I have recently reinstalled Windows 8 (64bit), and on a clean machine (i5-5200 with integrated graphics) with up-to-date drivers f.lux causes a) slowdown during startup and fast color fading b) hiccups every seconds, easily noticed during video playback or while smooth-scrolling in a browser.

    Reading the above I seem to experience precisely the same issues, although on quiet different hardware.

    These effects disappear completely closing f.lux, or with Safe Mode enabled. They also don't appear on two other machines where I run the program, both older that this one, both running Windows 7. One of them is a Core-2 laptop from 2007, so processor consumption does not seem the issue here.


  • f.lux team

    We are working on some fixes for the next version (will be more like safe mode), but to get GPU makers to fix slowdowns during transitions, we need specific information.

    I made a form to help record the details - please fill it out?

    https://docs.google.com/a/justgetflux.com/forms/d/1RV5IMX8Q-EccWN2B_G3-4W7JIwrimDNJ6TAHxxkHS_I/viewform



  • I made a form to help record the details - please fill it out?

    Er, the form cannot be accessed, even after logging in to Google Docs/Drive. Could you set it to public?


  • f.lux team

    @dreadnaut uh I set it that way, a second time. maybe it will work now. :)


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.