Think there's a glitch in your lighting formula



  • On my Windows 10 machine with all updated drivers, when I set the night mode light level the level actually becomes darker than that. It looks to me like the formula that determines light level is scaling down rather than up, and thus when I have my night level set to be 4200k the "currently" level will show me at less than that (3870k at the very start of dusk right now).

    Regardless of why though, it seems to me that the Night level should be a min, and thus my ever being below that is a clear bug.



  • You might have pressed Alt+Page Down. Press Alt+End once to see what happens.



  • Alt+End just seems to turn on the "disable for an hour" option, which still works fine. When I turn it off again though it reverts to the previous state in which my screen shows as being lower than my Night mode setting.

    If I press Alt+Page Up until it stops it still has me at a lower level than my Night mode setting.



  • @nataelj Alt + End will pause f.lux. To bring up the brightness do Alt + Page Up. It (I love this forum--closed the whole browser and text is still here! EVERY time!) will say "Full" to indicate the brightness level with a yellow slightly oval shape on the top right of the screen.



  • @nataelj said:

    Alt+End just seems to turn on the "disable for an hour" option, which still works fine. When I turn it off again though it reverts to the previous state in which my screen shows as being lower than my Night mode setting.

    If I press Alt+Page Up until it stops it still has me at a lower level than my Night mode setting.

    That sounds like a strange bug. I've never seen anyone else reporting this (and I practically live on this forum), so it might be something on your end that's causing it.



  • Hmm, okay, so for you then the "currently" number in your f.lux is higher than your night mode number even when it's active?

    If it's just me, how do I begin to identify what's causing it?



  • @nataelj said:

    Hmm, okay, so for you then the "currently" number in your f.lux is higher than your night mode number even when it's active?

    If it's just me, how do I begin to identify what's causing it?

    What? No. The 'Currently' number is always exactly where I expect it to be based on my current setting. Why would it be higher? Actually no, why would it be different than my setting? The only way it would be different is if I pressed Alt+Page Down.

    I have never seen this before, so I have no idea how anyone would begin figuring out what's causing it.



  • Wait, I'm confused. On mine the higher numbers show as brighter. As such, my Night mode number is lower than my Daytime number. My Current number should thus always be in between them, right? And the Night mode number should basically be a min unless I've artificially dimmed it further (e.g. with Alt+Page Down).

    Is that not correct? I'm skeptical that this issue is with my video drivers since f.lux itself is showing me a current number lower than night mode; that seems to be the problem to me. Either that or I'm misunderstanding something; if so, care to explain?



  • Oh, also, it should be different from your settings because the "Day" and "Night" levels basically function and ceiling and floors, and the automatic adjustment would then make it oscillate between the two. Thus outside the middle of night or full daylight your current shouldn't actually be at either setting level.

    Which makes me realize, maybe I should note that I have my location set and am having it auto-adjust for me based on time.



  • I don't understand the confusion. The "currently" number should simply match your current setting. Period. Why would it be different? The only way it would be different is if you have pressed Alt+Page Down or have disabled f.lux. This isn't complicated. Don't let it confuse you.

    Also, we can edit our posts.



  • Oh damn, I found it. Looking further I realized I had the "make screen warmer as the backlight dims" option on in the Extras (not sure if I did that or it's a default) but I turned that off and suddenly it's set to my Night mode option. And you're right, it's exactly equal to my night mode option. Seems a bit odd to me, I thought it would transition over time, but regardless that seems to have done the trick.

    That option actually makes a huge difference; even on fluorescent mode having that on made my screen WAY darker.



  • @nataelj said:

    Oh damn, I found it. Looking further I realized I had the "make screen warmer as the backlight dims" option on in the Extras (not sure if I did that or it's a default) but I turned that off and suddenly it's set to my Night mode option. And you're right, it's exactly equal to my night mode option. Seems a bit odd to me, I thought it would transition over time, but regardless that seems to have done the trick.

    That option actually makes a huge difference; even on fluorescent mode having that on made my screen WAY darker.

    It does transition over time, either 20 seconds or 1 hour - depending on your Transition Speed.

    Anyway, I am glad you found it. I knew it had to be something you did to f.lux because there's no other way I know of that you can change the color temperature that f.lux says it's displaying. So no, that's not the default setting. Not that I'm aware of anyway.

    Also, it's "warmer", not "darker". You're working with color temperatures. So for example: 1200K isn't darker than 6500K. It's just warmer. The perceived brightness is lower because there's a lot less blue light.



  • Yeah, it says warmer, but in practice it also equates to much darker. I was about ready to uninstall f.lux as being too dark for my screen on even the lightest setting. Remove that option and even a few shades darker setting is still lighter than it was before!

    Regardless, happy with the result now; thanks for talking it through with me!



  • @nataelj said:

    Yeah, it says warmer, but in practice it also equates to much darker. I was about ready to uninstall f.lux as being too dark for my screen on even the lightest setting. Remove that option and even a few shades darker setting is still lighter than it was before!

    Regardless, happy with the result now; thanks for talking it through with me!

    You're welcome. I hope you can enjoy f.lux now as much as the rest of us do. I refuse to live without it now. :)

    And it's not darker, that's an illusion due to the much lower level of blue light - your backlight's brightness is still the same, even when you change the "brightness" in f.lux. F.lux cannot and does not change the brightness of your display panel's backlight.



  • Not sure I buy that; when I have that setting on the "currently" number gets lower. That would indicate that it's actually darker.

    Regardless, whether actual or perception alone the difference was large.



  • @nataelj said:

    Not sure I buy that; when I have that setting on the "currently" number gets lower. That would indicate that it's actually darker.

    Regardless, whether actual or perception alone the difference was large.

    No, these are color temperatures, not brightness levels. A lower number is simply a warmer color temperature. So, 6400K is warmer than 6500K. It's not darker. Or 1200K is warmer than 6500K. It just looks darker because there's a lot less blue light.



  • @TwoCables We've discussed this before. 1200K is a lot darker than 6500K and less light will enter the users eye from the monitor because it's blocking almost 40% or more of the light output. Blue is very dark almost black, and green will look like very very dark teal / blue. It truly is darker but yes the backlight will not change and will continue to use the same amount of power.



  • Alright, fair enough. However, I should explain again that when I'm ready to "go red" at night, I replace both of my SWITCH 3-WAY (sorry for the caps, that's how they write it) with the red FEIT LED lamps: http://www.feit.com/led-lamps/performance/performance_led/performance_led/color_leds/color_led/a19-r-led

    Now, here's something interesting: as a test, I did this:

    1. Before swapping the lamps, I set both of my SWITCH 3-WAYs to their highest (75W equivalent) setting.
    2. I sat in my computer chair
    3. I closed my eyes
    4. After a few moments, I squinted with my eyes closed in order to block more light
    5. I repeated a few times in order to memorize the brightness with my eyes closed in a relaxed way and then the change to that brightness when I squint with my eyes closed.
    6. I then did the same thing after "going red" (switching to my red LED lamps)
      .

    What I found with just my red LED lamps is, the brightness is the same and so is the difference in that brightness. The only difference I detected was the color. I was shocked. I had to do this several times just to make sure, but yeah, the brightness is the same for me.

    Then I did it with my monitor with my lights off, and I had the same results. F.lux at 6500K vs. 800K. The brightness only seems different, but I'm finding it's really not.



  • @TwoCables Well, yeah the red WILL (or should) be the same brightness, I understand what you're getting at now. So yes it is actually a similar brightness so I guess you're right, but it IS less light.



  • @Tungsten_smooth said:

    @TwoCables Well, yeah the red WILL (or should) be the same brightness, I understand what you're getting at now. So yes it is actually a similar brightness so I guess you're right, but it IS less light.

    Yeah, that's all I've ever been saying, and it's only a little bit less light - and yes, of course I am aware that it's due to having less or no blue and green.



  • @TwoCables Haha, I wasn't thinking of the way you were thinking of it until you explained it a bit more. Yeah, makes great sense!


  • f.lux team

    Yep, I did turn this on by default. It's trying to emulate incandescent lights.

    This feature does not run during the daytime, and it probably shouldn't run for "dimming above half" or some threshold like that. The goal is to do something nicer when you're using f.lux in a very dark room, but it sure makes the UI confusing because you choose a color and then it changes it.

    I've already turned it off in my development build...will sort out what to do in the next version.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.