flux overriding brightness in openGL games



  • Whenever I have flux running I cant brighten up my openGL game, the brighter picture flashes shortly but then reverts to the darkest setting.

    I don't mind the color change but I need to see what I'm doing in this game.

    "Disable 1 hour" does not change this, I have to exit flux completely.



  • I'm fairly new to using f.lux - I love it! Great application. However, I also love my game and it's waaaay to dark (so dark it causes eye strain) without adjusting the gamma.

    I have the same issue, even if I "Disable f.lux for 1 hour" it still prevents my game brightness setting from working. Just like your experience, it briefly flashes brighter then back to the same darkness, regardless of what brightness I try to set.

    I don't know if I can keep using this wonderful program if I have to uninstall it every time I want to play this game?!?



  • You don't have to uninstall it. Just right-click the icon in the Notification Area and choose "Exit f.lux". Open it back up when you're done gaming.



  • Thanks.

    After a little more reading I found that if you turn the brightness up to max with the ALT-PGUP key then it has no effect on the in game setting. Minor annoyance - when you press the ALT-PGUP to change brightness it either brings the f.lux app to foreground or at least it causes the game to no longer be the foreground/full screen app. Not a big deal of course. Having the benefit of f.lux is worth a lot more than the inconvenience now that I know the "brightness" setting works even though "disabling" it doesn't.

    Maybe I'll figure out how to setup a script which closes flux, launches my game, then re-launches flux when I exit the game :)



  • Whoa, weird. So, pressing Alt+Page Up even though it's already maxed out works? I am asking because I have this problem in a couple of my games but I lack the time right now to test them.



  • @sleepcat Run the game in "full window", "borderless windowed", or just windowed mode if that's the only other option.



  • @TwoCables When I turn brightness all the way up in f.lux it lets the game's own settings work normally for me.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.