[Win10] Darkroom causes screen to become soild red with dots of black.



  • @Tungsten_smooth said:

    @Gentz O.K. so clearly there's something set wrong.

    Try this, if your monitor has presets like movie, picture, game, then try the one that says "sRGB". Now if it allows, set the contrast low on this mode as well. We'll eventually find the cause!

    My screen got 5: "User, eco, normal, graphics, movie". Shuffled through them and only the screen brightness changed. I also had a color temp setting. I shuffled through them to and it also did nothing.

    Then I found a color amount setting. I set it to 10% red and 100% green and blue. So if theirs any green or blue to be rendered it would then render them at max capacity. All I had was a dim screen.



  • @Gentz Can you go to a system / info menu to locate the model of the monitor? Maybe we're missing something.



  • @Gentz Have you expanded the color range?

    Uh, if that's a white page, darkroom should show it with a

    black background and red text.
    

    It actually looks like your using the Ember 1200K setting, OR you are using Darkroom mode, and have somehow inverted the colors, which WILL strongly reduce contrast. Would you please have a look into it when you get time?



  • S/N: ETLTKORO29422056B82442?
    Is that the model? All I remember is its an acer and its 1980x1080.

    Edit: Forgot about Dxdiag, their always good.

    DXDIAG



  • I have expanded the color range but currently at day its set to 5500K and at night to 4400k so I don't see why it would affect it. Also the photos were taken at day. I've tried setting both to 6500k but same results. I've also not inverted any colors. When not in DarkMode I can see it as white, like it should be.

    Also: This issue was also happening before I upgraded from win 8 to win 10, but I've always been to lazy to report it.



  • @Gentz can you take a picture of this page in darkroom mode so I really understand the issue?

    It just seems inverted somehow, so maybe it's just that webpage.





  • @Gentz yep something is wrong with your color settings. It's way too strong of an effect (I can't see ANY words) and also it's not inverting the screen.

    Please hold the Windows key and tap the + on the number pad. You can zoom out with "windows key and -"

    Do CTRL Alt i
    This will invert the colors on the screen. It's the only way I know how, hopefully that will make it look like it should. Then we can try to figure out what would stop f.lux from inverting the colors once it goes red.

    Also if you don't mind, take a few pictures of the AMD color settings. I know you've set it to ignore them but maybe there's something that's still changing stuff.



  • Wow. You can invert the inversion that's done by Darkroom Mode. It's like simply setting f.lux to 800K. Nice trick.



  • No Zoom:
    http://s8.postimg.org/e6jw84rfp/IMG_20160112_170550.jpg
    Zoom (No DIF):
    http://s8.postimg.org/celvg41r9/IMG_20160112_170647.jpg

    Inverted: (Kinda works, altho menus are now SOLID RED, making the mode still unusable)
    http://s8.postimg.org/h0rmzbizp/IMG_20160112_170713.jpg



  • Every page in Catalyst:
    http://postimg.org/gallery/w7txbpiw/14cc3374/

    Screenshot 259 and 264* are of interest as they are the only ones which directly affect the brightness, contrasts, hue, saturation and color temp directly.

    *Thier is not 264+ images, its just my screenshot folder HAD over things. Images are 256 to 283.



  • Try toggling and experimenting with the Color Temperature Control settings.





  • Do you have anything else running that might be messing with the display output?



  • @Gentz yep when you inverted colors with the zoom, it looks about as expected.

    We still need to figure out what is preventing f.lux from inverting your colors.

    I just say uninstall your AMD graphics driver (and delete it's settings if you get that option) and reinstall (a clean install not using any current settings if possible), because I'm out of ideas at this point. Thank you so much for being so responsive and trying all suggestions! It really is appreciated.



  • @Tungsten_smooth said:

    @Gentz yep when you inverted colors with the zoom, it looks about as expected.

    We still need to figure out what is preventing f.lux from inverting your colors.

    I just say uninstall your AMD graphics driver (and delete it's settings if you get that option) and reinstall (a clean install not using any current settings if possible), because I'm out of ideas at this point. Thank you so much for being so responsive and trying all suggestions! It really is appreciated.

    Do you mean you expected everything to be surrounded by a red like that? It looks strange, like everything has a red frosting on it or something.



  • @TwoCables Nope. Or atleast none that I know of.



  • Perhaps some proprietary software is running that messes with things like color and whatnot.



  • @Tungsten_smooth Removed AMD Catalyst, and same results. :(

    @TwoCables Maybe. Tracking down a program which may or may not exist doesn't seem fun. I imagine it might be a game, but I don't got any running right now so it probably isn't.



  • @Gentz said:

    @Tungsten_smooth Removed AMD Catalyst, and same results. :(

    @TwoCables Maybe. Tracking down a program which may or may not exist doesn't seem fun. I imagine it might be a game, but I don't got any running right now so it probably isn't.

    Do you know the items in your Notification Area? Or do you never look at them?



  • @Gentz removing catalyst control center does not remove the driver. You'll have to go to device manager now to uninstall the graphics driver (assuming you could have done that with the control center).

    Please remove the driver, and re download from the AMD website.

    I want to stress this because when you took the screen shot, it said the next update check was Jan 5. Oh that was just for the program well anyway I think it's got to be driver related.



  • @TwoCables said:

    @Gentz said:

    @Tungsten_smooth Removed AMD Catalyst, and same results. :(

    @TwoCables Maybe. Tracking down a program which may or may not exist doesn't seem fun. I imagine it might be a game, but I don't got any running right now so it probably isn't.

    Do you know the items in your Notification Area? Or do you never look at them?

    Yup I know what's their, none of em' should be affecting the monitor in anyway (other than rendering windows\menus to the screen).

    @Tungsten_smooth said:

    @Gentz removing catalyst control center does not remove the driver. You'll have to go to device manager now to uninstall the graphics driver (assuming you could have done that with the control center).

    Please remove the driver, and re download from the AMD website.

    I want to stress this because when you took the screen shot, it said the next update check was Jan 5. Oh that was just for the program well anyway I think it's got to be driver related.

    Ok. I'll tell you when I'm finished.



  • Do I remove the display adapter?



  • @Gentz Before you do that just search "uninstall programs" for the driver instead

    uh yes I believe that's correct--windows should revert to basic so your screen isn't black.



  • @Tungsten_smooth Used AMD clean uninstall to uninstall EVERYTHING from AMD. Even the AMD Audio drivers! It also cleans the register.

    Now using the new AMD Crimson drivers for my APU (I specifically went under my APU's driver list thingy, so not just a random driver) which were just released this year. AND darkmode still ain't working. :(

    On another note: I just remembered that darkmode didn't work even when I had Windows 8.1. So it can't be from my upgrade to Win 10.



  • I don't agree that this might be a driver issue (I never thought it was). I think that it's being caused by some other software that's running. Either that, or it's a color profile.

    Is this a laptop? Or is it a pre-built 'desktop' computer (like a tower)? Or is it a computer that you built?



  • @TwoCables Prebuilt desktop.
    http://www.staples.ca/StaplesProductDisplay?catalogIdentifier=2-CA&langId=1&productId=4265362&storeId=20001&externalize=certona&cm_mmc=AFF--SBD--LinkShare-CAqD7bLWUPI--1--10&siteID=CAqD7bLWUPI-jP8i9g7MyIsENp6xhnrpmQ

    Edit: wrong website... same specs tho so doesn't really matter.



  • All I'm getting is a page that tells me to enter a Canadian postal code. I didn't just blindly click the clickable part either: I copied the whole thing.

    Anyway, I'm not concerned about specs: I want to see what software is likely installed that could be related to the GPU or display or both.



  • @TwoCables Yep, it's definitely time to move to the software side of things. But, go to the color management stuff in windows, and find out what color profiles are being used.



  • @TwoCables Not any software I know of that change the color profile.

    @Tungsten_smooth said:

    @TwoCables Yep, it's definitely time to move to the software side of things. But, go to the color management stuff in windows, and find out what color profiles are being used.

    My ICC profile is 'sRBG display profile with display hardware configuration derived from calibration (default)'
    Does that help?



  • A little bit. Have you ever gone through the Windows Display Color Calibration tool? I doubt that this is the culprit or else more people would have this problem, but hey - give it a shot. Complete the whole thing, you don't have to be precise - just as long as you finish it.

    I don't know how to access it in Windows 10, but in Windows 7 all I have to do is open the Start menu and type "calibrate".



  • @TwoCables @Gentz and if that doesn't work, just delete the color profile if possible. Maybe it's corrupted. (You may not be able to delete it if it's the only one, I don't know).



  • Hey Gentz, I'm curious: why do you want to use Darkroom Mode? I'm asking because if it's so that you can get 800K anytime you want, then I have an easy way to do that.



  • @TwoCables said:

    A little bit. Have you ever gone through the Windows Display Color Calibration tool? I doubt that this is the culprit or else more people would have this problem, but hey - give it a shot. Complete the whole thing, you don't have to be precise - just as long as you finish it.

    I don't know how to access it in Windows 10, but in Windows 7 all I have to do is open the Start menu and type "calibrate".

    I've done it already. Also have cleartype (or whatever it was called) enabled.

    @TwoCables said:

    Hey Gentz, I'm curious: why do you want to use Darkroom Mode? I'm asking because if it's so that you can get 800K anytime you want, then I have an easy way to do that.

    Heard it was cool, so wanted to see what it does, that's all.
    I've also been wondering how 800k looks like so could you show me how to do that?

    @Tungsten_smooth said:

    @TwoCables @Gentz and if that doesn't work, just delete the color profile if possible. Maybe it's corrupted. (You may not be able to delete it if it's the only one, I don't know).

    I just redid a calibration, so it should be reseted. Darkroom mode still not workin'



  • @Gentz This is getting a bit crazy. To heck with it, let's try two things:

    • Set both f.lux sliders to 6500K.

    • In the hidden icons, right click and exit f.lux.

    • Check to make sure it's not listed in the task manager.

    • Uninstall f.lux and tell it to REVERT COLOR SETTINGS, this undoes the expanded color range. Please reboot, so the changes will take effect.

    • After you have rebooted, install f.lux again, and expand the color range, and reboot once more.

    • Try Darkroom mode.

    Trial / Error 2:
    O.K. that probably won't fix it, so my thought is that maybe the GPU in the APU just won't do it. I'm not sure. So to really finish off this problem, would you happen to have a graphics card that you could put into the machine? I'm starting to think that for some reason the GPU on the CPU just isn't able to do the color change. I hope this would not be the case, but it would rule out some stuff and help with configuration maybe.



  • @Tungsten_smooth said:

    @Gentz This is getting a bit crazy. To heck with it, let's try two things:

    • Set both f.lux sliders to 6500K.

    • In the hidden icons, right click and exit f.lux.

    • Check to make sure it's not listed in the task manager.

    • Uninstall f.lux and tell it to REVERT COLOR SETTINGS, this undoes the expanded color range. Please reboot, so the changes will take effect.

    • After you have rebooted, install f.lux again, and expand the color range, and reboot once more.

    • Try Darkroom mode.

    I had reinstalled flux before I posted here. :/

    Trial / Error 2:
    O.K. that probably won't fix it, so my thought is that maybe the GPU in the APU just won't do it. I'm not sure. So to really finish off this problem, would you happen to have a graphics card that you could put into the machine? I'm starting to think that for some reason the GPU on the CPU just isn't able to do the color change. I hope this would not be the case, but it would rule out some stuff and help with configuration maybe.

    I don't have a GPU another GPU. :/ When my buddy finishes with what he's doing on his computer I'm gonna try to test it out on his.



  • Sorry for going off topic again but just a quick note for everybody wondering about quotes and code blocks a few days ago, this forum uses the markdown syntax.

    You can read a lot about it here: http://daringfireball.net/projects/markdown/syntax#precode

    Sorry, but I couldn't hold back :P


  • @Gentz O.K. does this person also have an AMD APU as well? That's what we're testing!

    Edit: saw question about 800K. Don't get crazy, go slowly on this part and keep the mouse steady.

    Open start menu and type in
    regedit
    Open the registry editor. Do a find for
    flux
    change the "indoor" value to 800K and exit / reopen f.lux
    (Don't change the setting from hex to decimal yet) You'll see what 30,000K looks like. Then you can take it to decimal.



  • @Gentz said:

    @TwoCables said:

    A little bit. Have you ever gone through the Windows Display Color Calibration tool? I doubt that this is the culprit or else more people would have this problem, but hey - give it a shot. Complete the whole thing, you don't have to be precise - just as long as you finish it.

    I don't know how to access it in Windows 10, but in Windows 7 all I have to do is open the Start menu and type "calibrate".

    I've done it already. Also have cleartype (or whatever it was called) enabled.

    @TwoCables said:

    Hey Gentz, I'm curious: why do you want to use Darkroom Mode? I'm asking because if it's so that you can get 800K anytime you want, then I have an easy way to do that.

    Heard it was cool, so wanted to see what it does, that's all.
    I've also been wondering how 800k looks like so could you show me how to do that?

    @Tungsten_smooth said:

    @TwoCables @Gentz and if that doesn't work, just delete the color profile if possible. Maybe it's corrupted. (You may not be able to delete it if it's the only one, I don't know).

    I just redid a calibration, so it should be reseted. Darkroom mode still not workin'

    Here's how I do it. What I'm about to describe to you will enable you to change to any color temperature you want at any time of day.This looks difficult, but in the end, it's extremely easy.

    1. Open Registry Editor and go here: HKEY_CURRENT_USER\Software\Michael Herf\flux\Preferences
    2. In the right-hand pane, double-click "Indoor" (this one controls the 'At night' color temperature)
    3. Select "Decimal"
    4. Now type your desired color temperature, without "K". So, 800K would simply be '800'.
    5. Press Enter
    6. Double-click "Outdoor" (this one controls 'Daytime')
    7. Select "Decimal"
    8. Type the same color temperature that you typed for 'Indoor' (I'm not sure why it has to be the same, but so far it seems to me that it does)
    9. Press Enter
    10. In the left-hand pane, right-click "Preferences"
    11. Choose "Export"
    12. Give it a name you'll remember and that's easy for you to type and save it to anywhere you want. I named mine "800K"
    13. Close Registry Editor

    .
    Now with both values set to '800', all you have to do is Exit f.lux and then open it back up. I mean, you need to completely exit the program and then start it back up. At this point, it should start warming up to 800K.

    The only bad thing is, once you choose any other color temperature, you have to change these values in the Registry again. This is why I had you make these .reg files using the 'Export' function. ;) So, let's try that:

    1. Choose a different color temperature so that f.lux is no longer at 800K. Any color temperature will do.
    2. Open the Start Menu and type the name of your exported .reg file. Mine is "800K.reg", so I open the Start Menu and type 800K and then press Enter. When I press Enter, Registry Editor tells me what I'm doing and asks me if I'm sure. So I press Enter again because the 'Yes' button is already selected. Then it tells me that the operation has completed and then I'm done. So in a nutshell, I open the Start Menu, type "800K", and then press Enter three times in a row. lol Note: If it's easier for you to just go directly to the file and then open it that way, then do so. All that really matters is that you do it - I'm just trying to give you the easiest way to do it, that's all.
    3. Completely exit f.lux and then open it back up

    .
    So now any time you want to change to 800K, all you have to do is "merge" your exported .reg file and then restart f.lux!



  • @Tungsten_smooth said:

    @Gentz O.K. does this person also have an AMD APU as well? That's what we're testing!

    No, intel HD graphics.

    @Tungsten_smooth said:

    Edit: saw question about 800K. Don't get crazy, go slowly on this part and keep the mouse steady.

    Open start menu and type in
    regedit
    Open the registry editor. Do a find for
    flux
    change the "indoor" value to 800K and exit / reopen f.lux
    (Don't change the setting from hex to decimal yet) You'll see what 30,000K looks like. Then you can take it to decimal.

    Well, I can't find it. Oh well.

    Anyway folks, I think I've bothered you guys so much and I'd like to thank you for your efforts but at this point I think the hassle is worth more than its worth.



  • You can't find it? Look at my post directly above your latest one here. Tungsten_smooth didn't explain how to do it, but I did.



  • @TwoCables said:

    You can't find it? Look at my post directly above your latest one here. Tungsten_smooth didn't explain how to do it, but I did.

    Now I can find it, thanks!



  • @Gentz said:

    @TwoCables said:

    You can't find it? Look at my post directly above your latest one here. Tungsten_smooth didn't explain how to do it, but I did.

    Now I can find it, thanks!

    You're welcome. I'm surprised I had to tell you to look at my post. It's huge!

    Anyway, please post again when you complete all these steps. I want to know whether this works for you and what you think. Of course, I will also be here if you have any questions.



  • @TwoCables said:

    @Gentz said:

    @TwoCables said:

    You can't find it? Look at my post directly above your latest one here. Tungsten_smooth didn't explain how to do it, but I did.

    Now I can find it, thanks!

    You're welcome. I'm surprised I had to tell you to look at my post. It's huge!

    The thing wouldn't load it untell I refreshed. When you told me to look at it I got an E-mail, otherwise I would've never know about it.

    Anyway, please post again when you complete all these steps. I want to know whether this works for you and what you think. Of course, I will also be here if you have any questions.

    And it works... YAY. Dimm the brightness a little ad its perferct for working in pitch black! YAY!



  • @Gentz said:

    @TwoCables said:

    @Gentz said:

    @TwoCables said:

    You can't find it? Look at my post directly above your latest one here. Tungsten_smooth didn't explain how to do it, but I did.

    Now I can find it, thanks!

    You're welcome. I'm surprised I had to tell you to look at my post. It's huge!

    The thing wouldn't load it untell I refreshed. When you told me to look at it I got an E-mail, otherwise I would've never know about it.

    Anyway, please post again when you complete all these steps. I want to know whether this works for you and what you think. Of course, I will also be here if you have any questions.

    And it works... YAY. Dimm the brightness a little ad its perferct for working in pitch black! YAY!

    Yeah, I freakin' love this little trick because it enables me to change the color temperature regardless of what time of day it is!

    Then, changing to 6500K is a snap: just choose 6500K in the f.lux interface!

    I've been doing it like this for a couple of weeks now, and it has made f.lux become 100x better for me.



  • @Gentz Now you can open the magnifier and invert the colors (ctrl alt i). I think it's the APU not understanding the color inversion part.



  • @Tungsten_smooth said:

    @Gentz Now you can open the magnifier and invert the colors (ctrl alt i). I think it's the APU not understanding the color inversion part.

    Yeah, something somewhere is definitely not allowing f.lux to work correctly. :/