Dual Monitor Flickering



  • I have an AOC G2460P as my main monitory and my secondary monitor is an Asus VS228.

    I updated my graphics card driver, but my main monitor keeps flickering from orange to white every 3-5 seconds, while my second monitor is perfectly fine. I'm running on Windows 7. Is there any way to fix this?



  • I'm getting the same thing. I'm running a GTX 970 video card, two monitors connected via DVI. Primary monitor, Asus VG248QE, runs fine. The secondary monitor, Samsung 216BW, flickers at about the same rate. Turning to Movie Mode seems to make it significantly less bad once it adjusts, but i definitely didn't have this problem in Windows 8.



  • Did a clean install of Windows 10 recently, this is also happening to me. My VG248QE is fine, but my other monitor (VE248H) is flickering random shades of orange/white (and in between) every few seconds. Pretty distracting. Didn't have this on 8.1!



  • I'll add that my drivers are brand new, fully updated drivers. I can't find a DCC/CI option on the monitor in question, where my VG248 does feature it (turning that on or off makes no difference with the affected monitor). Oh, and Safe Mode seems to make no difference either, as I've tried that. Movie mode, of course, only works for a few hours.



  • Well so far it just seems to be having a secondary monitor will cause this issue.

    Try cloning the display and note the results.



  • So, good call. I tried three things. I tried cloning, I tried setting the Samsung as my single monitor, and I tried setting the Samsung as my primary display while leaving the Asus enabled.

    The first two worked. Took care of the problem immediately. If the display is cloned or alone, there's no flicker - just like in Windows 8 and 7. If it's an extended display, the flicker is there.

    A common link:
    All three of us have monitors that run at 144Hz. The VG248QE and the AOC G2460P, while the Asus VS228, Samsung 216BW, and the Asus VE248H are all, I believe, standard 60 Hz refresh.

    My best guess is that either Win10 or the video card's Win10 drivers are handling how it works with the two refresh rates differently. I didn't see anyone else specify which card they're rolling with, but my guess is it's probably Nvidia.

    I hope this helps the developers narrow down the cause.



  • I have the same issue since I upgraded to Win 10. On 8.1 f.lux worked fine, but since upgrading my second monitor (LG E2340V) now flickers.

    I also have a 144 Hz monitor as my primary, the Asus VG248QE. My second monitor is connected via HDMI to my GTX 770 and operates in YCbCr444 colour format (set via the Nvidia Control Panel). I have the latest Nvidia drivers appropriate for my system (353.62).

    Not sure what's causing the issue and the flickering is random, though it always seems to occur at the same time every second, as if the flickering is synced to a clock. Sometimes it'll happen 2, 6, 10 times in a row and there won't be any flickering for 10 - 30 seconds, then it repeats. Almost seems like maybe the OS is trying to correct the gamma that f.lux is messing with, though the flickering of colour doesn't seem that severe so I'm not sure. And no idea why it's as random as it is.



  • @Spartangy said:

    "and operates in YCbCr444 colour format" How did you set that? I want mine on REGULAR RGB! Screw limited 16-235 color space.



  • @timpster it's under resolution options in the Nvidia Control Panel, here at the bottom: http://i.imgur.com/UStZuAl.png

    It's only available is you use HDMI.



  • I was having this same issue with my 980GTX and quad monitor setup. When looking at the windows 10 display settings I noticed a 5th display. It was Virtual display created by intel graphics by default. I removed this display by clicking disconnect display in the 'Multiple Displays' dropdown and now the flickering has vanished.

    Still can't get rid of the super bright cursor I'm getting yet.



  • @peter You can run the windows 7 magnifier. Hold windows key and +. Set it back to 100% if needed.



  • I read multiple messages about flickering and going to white once in a while. I had the same problems on windows 7. It started after windows updated my video drivers. Because a second update failed, and I ran into other problems I found a solution, that included removing the existing video driver, and installing the ones from the manufacturer website. To my surprise, the flickering was gone too.
    This is what I did. I am not saying it will be a solution to everyone, but it helped me.

    • First find out what video card you have: On the control panel, type "Device manager" (without quotes) in the search box. Pick the one under system. You can find your video adapter under "Display adapters", near the top.
    • Go to the manufacturer's website (Nvidia, Intel) or google for your video card name + number, and download the driver compatible with your windows version. Be sure to download the driver that exactly matches your video card.
    • Google for DDU (display driver uninstaller), and download it from a reliable website
    • Boot into safe mode. Until windows 8 it can be done by pressing f8 during boot. Your screen will have very big icons and text.
    • Use DDU to remove the current video driver, and reboot when done (recommended option)
    • During the next boot, go to safe mode again. Now install the original video driver you just downloaded. I have on-board Nvidia, and an external Intel graphics card (or the other way around) So I had to run two installers.

    That's about it. During the next boot, your windows will run with the video drivers from the manufacturer, not the ones from windows.
    If you don't feel safe doing it, ask someone to help you.



  • I had this problem too.

    Fix it by going into your monitor settings and turning off any features that automatically control the color balance of the monitor. Just set it to manual and it will stop flickering/trying to go back to white.



  • @Tungsten_smooth
    I can confirm this happens with single monitors as well. It's particularly noticeable in outlook. The preview message pane's border keeps flickering. I thought it could be an issue with Display fusion so investigating that.



  • I wanted to note that expanding the range in the Flux extras menu does the trick. I too ran into problems when I installed a second monitor (Windows 7). The flickering is resolved and Flux works again as usual.



  • Just wanted to chime in to report that the following worked for me:

    • Right-click the f.lux tray icon and select Settings.
    • Move the At night: slider located under 1. Adjust your lighting for day and night to the right, then back to the left as far as it will go
    • Select Done

    When I first opened this menu, the At Night slider was set at 3400 K. I moved the slider right and back to the left, and it stopped at 3700 K. Not sure what the issue is, but adjusting the slider seems to have resolved the issue for me.

    Also, the "Expand Range" option NiftyStuff mentions was in the Settings menu next to the Done button for me. I'm also enabling that as an additional measure, thanks for the tip!



  • @NiftyStuff said:

    I wanted to note that expanding the range in the Flux extras menu does the trick. I too ran into problems when I installed a second monitor (Windows 7). The flickering is resolved and Flux works again as usual.

    Thanks so much NiftyStuff!! I moved the slider to the right as PorcoBrosso did and moved it back to 3100K, the "Expand Range" option popped up, clicked on it, restart, and everything is now back to normal. Perfect!



  • @NiftyStuff Just wanna let you know, I created an account to thank you for your solution, which worked for my dual monitor setup. I used a disposable email, and will never visit this site again, but your solution worked when no others worked and I wanted to say thanks


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.