f.lux stopped working after upgrading to Windows 10



  • It is still showing icon on taskbar and it is still seem like working properly but no changes in the screen light filter.



  • Yeah, same here. I'm going to guess they'll be releasing optimization shortly. For now, I have to wear sunglasses.


  • f.lux team

    Make sure you install/update your video driver.

    For some of the technical previews, it would install no manufacturer driver at all (and the basic one doesn't work with f.lux). But I assume there is a driver now that the OS has shipped.



  • Same problem here, just upgraded to stable Windows 10 and f.lux doesn't work.

    I have a i7-4790K, GTX 970, Gigabyte motherboard. On the latest drivers from NVidia.



  • Already had to upgrade my graphics driver because of the dedicated graphics issue when updating to Windows 10. Flu.x just caused my screen to flicker a bunch when turning to sunset mode. Disabled for one hour. We'll see how it goes. I'll miss it if I have to turn it off for any length of time.


  • f.lux team

    Keep us posted - and when possible let us know what kind of hardware you have, especially for laptops. It's working fine on my Surface 3 with the exception of a flash when I rotate it at night.



  • Not working here either.

    Custom built, GTX 980, i7 4970k, ASRock motherboard. I'm on the latest drivers from NVidia.



  • @lorna Phew, I was getting a little nervous there. I have a SP3 and I'm running Windows 10 and I can't wait to try this out. I can't believe I haven't heard about this software until yesterday when a user called in asking for approval to run this on a company computer (AppLocker in full effect boyeee).


  • Android

    Registered to comment here. Im on Surface Pro 3 and flux works until i rotate the screen. Where it returns to normal brightness and I have to set it again.

    I primarily use flux for lowering brightness with Alt PgDwn and I wish there was an easier way to do it on a tablet



  • Installed in clean Windows 10 install. It works for one minute, changing down to 3400, and then, quite rudely, snaps back to white! When I exit f.lux and start it again, it does the same thing. I have onboard graphics ATI Radeon 3000.



  • @kavlito said:

    Installed in clean Windows 10 install. It works for one minute, changing down to 3400, and then, quite rudely, snaps back to white! When I exit f.lux and start it again, it does the same thing. I have onboard graphics ATI Radeon 3000.

    After rebooting, it seems to be working consistently now!!!!



  • IMHO the issue seems to be that when Windows 10 is installed, it replaces the original driver for the Intel Integrated graphics card with a generic windows driver. The issue was solved {seems like only for the model mentioned below since it didn't work for @gaui } after downloading the driver for Intel integrated graphics card from here https://downloadcenter.intel.com/ ; Although only drivers for Windows 8.1 are available with Intel, I have had no issue due to that, so far by using them on Windows 10.
    Also don't forget to download the drivers for Nvidia or ATI

    Computer Specs:

    1. ASUS G551 ; Intel HD Graphics 4600 with Nvidia GEFORCE GTX 860M

    Issues before the above suggested fix,

    1. F.lux not dimming the screen
    2. F.lux extras not working and not showing up in menus after reboot and reinstall
    3. Brightness control of monitor not working
    4. Projection to alternate monitor not working

    After Fix

    1. No issues at all :)


  • Did as rpn suggested, installed the latest Intel HD Graphics driver from Intel site. Didn't work. Even tried afterwards to disable the integrated graphics card. No go. f.lux is now in night mode (3400K) but still the screen is bright like it's daytime (6500K).

    Hoping for a fix from f.lux team.


  • f.lux team

    Yes we really need a working video driver to make f.lux work.

    I am hearing that WDDM 2.0 was a major change, so Google that if you want to read up. I guess we wait and see if the drivers get better--they kinda have to!



  • Hi - Love f.lux. Great concept / product.

    I got it to work with WIndows 10 (upgrading graphics driver).

    But am wondering if it's causing the operating system to reset to BIOS somehow. I've had Win 10 crash 6x since I installed it. And so far this morning, after turning off f.lux, Windows 10 hasn't crashed at all. Yet.

    Coincidence? Dumb luck? or absolutely nothing to do with f.lux?

    FYI.



  • @gaui Hi, sorry it didn't work for you :( . The solution worked for me on two ASUS laptops one an N53 (2011) and a G551 (2014), so I guess maybe because you have a different specification (a more recent Intel board) ¯\(º_º)/¯ . Hopefully they will come out with better drivers. I have changed my earlier comment accordingly.



  • Howdy! I just upgraded to 10 a couple hours ago. I'm running a GTX 560 (I know) with the most recent drivers from nVidia.

    f.lux still works, but instead of tinting my screen shades of orange, it's now turning it sickly shades of pink...

    It's still an improvement over computing at full brightness, but it's rather unpleasant to look at, and it's not as "natural" a look. Indeed, I'd have a hard time watching a movie in movie mode at the moment.



  • This post is deleted!


  • A little update. I have dual monitor. When the display is duplicated, f.lux works in my secondary display but not on my primary one. I changed it so secondary extends primary, then f.lux works on both. Any idea?



  • Hi f.lux team,

    f.lux stopped working for me too, after upgrading to Windows 10. System and driver details below:

    Windows 10 64-bit (had been Windows 8.1 64-bit)
    Intel HD 4000 integrated graphics (no discrete graphics)
    HD 4000 driver version: 10.18.10.4252

    Note that this is not the most recent version that I downloaded. It might be what Intel is calling the Beta driver for Windows 10. See here.

    The last one I installed was 10.18.10.4226, which is the most recent production version. See here.

    The beta driver for Windows 10 must have been installed by Windows Update, because Intel's page for it says that it can only be installed via Windows Update. It must have been automatic. Well, I don't know if the 4252 version I have is the beta, but since it's a higher number than 4226, and it's not listed anywhere in the available downloads, I assume it's the beta.

    CPU: Intel Ivy Bridge Core i5--3337U.

    From Windows systeminfo command, the specific OS version is: 10.0.10240 N/A Build 10240

    It's a Sony Vaio T-Series laptop.

    Cheers,

    joe



  • @gaui said:

    A little update. I have dual monitor. When the display is duplicated, f.lux works in my secondary display but not on my primary one. I changed it so secondary extends primary, then f.lux works on both. Any idea?

    I have my pc plugged to my TV. f.lux only works on my TV (the duplicated display) but it also works on any game I play.
    Even if I don't have my TV on, whenever I open a program that has Full Screen Mode (like games), f.lux works only on that program but not my windows desktop. I have no idea why this is happening but seems so weird



  • @don_isauro said:

    @gaui said:

    A little update. I have dual monitor. When the display is duplicated, f.lux works in my secondary display but not on my primary one. I changed it so secondary extends primary, then f.lux works on both. Any idea?

    I have my pc plugged to my TV. f.lux only works on my TV (the duplicated display) but it also works on any game I play.
    Even if I don't have my TV on, whenever I open a program that has Full Screen Mode (like games), f.lux works only on that program but not my windows desktop. I have no idea why this is happening but seems so weird

    Experiencing same issue as these guys.
    Whenever I have it set to "Duplicate these displays" it will only display flux on my secondary monitor, unless I change the second monitor off completely of have it on "Extend these displays."



  • Same here I've barely had it for a week then upgraded to windows 10, I miss it already, really relaxed me for long sessions of desktop time.



  • Custom build i7-4770k, GTX 760 here, interesting observations
    I have two monitors (one is running via DP and one via HDMI). The DisplayPort connection is fluxing fine. The HDMI monitor (which adapts to DVI on my motherboard) does not want to work, but another pure HDMI connection which goes via a receiver to a projector, and is mirroring the non-fluxxing monitor, does work.
    I hope I can figure this out as I'm currently staying up coding until 5pm and not getting tired, and screwing up my rhythym.



  • @jccrussell said:

    Custom build i7-4770k, GTX 760 here, interesting observations
    I have two monitors (one is running via DP and one via HDMI). The DisplayPort connection is fluxing fine. The HDMI monitor (which adapts to DVI on my motherboard) does not want to work, but another pure HDMI connection which goes via a receiver to a projector, and is mirroring the non-fluxxing monitor, does work.
    I hope I can figure this out as I'm currently staying up coding until 5pm and not getting tired, and screwing up my rhythym.

    Yeah there seems to be some issues with dual monitors. I'm not sure how to assist you, but the dual monitor part that I'm glad you mentioned really causes issues.



  • I have an ASUS netbook X202E. Not much of a techie and would love a simple fix. Lost f.lux when I upgraded to windows 10 and really miss it.



  • @Kalikot on a surface you can use Fn+Del and Fn+Backspace to change the brightness :)



  • I have the same problem with the duplicated monitors. It won't dim my main display unless I unplug the duplicate. i7-4770k, GTX 970, both on DVI-D.



  • Since the W10 upgrade (64bit) Flux does not work in full screen applications.

    I have a laptop with Nvidia 750, and Intel Hd4400 both have the latest drivers, only solution is to use windowed mode, very frustrating because windowed degrades game performance.



  • This post is deleted!


  • @asouidfasd8f

    f.lux does NOT Let me rephrase it:

    DirectX 9 does NOT support any gamma color changes. It will work if it's in game, but it will not follow what's on the desktop. Any game that uses DirectX 10 or higher should not have this issue.



  • @timpster

    Sadly not the case, it is the same across all fullscreen games regardless of DX version, I've tried it in games with 9,10,11.

    Previously in Windows 8 it worked, but something has changed with the setgammaramp option in Windows 10, and the only way to use flux in fullscreen games is windowed mode, the problem is, this reduces FPS significantly

    I was using a program called color clutch to inject the gamme profile lock into the game dll but it doesn't work most of the time.

    I've tried basically everything.



  • Hello,

    I had Windows 10 Pro on my notebook and f:lux worked perfectly until a few days ago when my system got automatically updated to the Win10 Anniversary edition (version 1607). After this the screen just cycles from bright to warmer and then bright again and then warmer again quite fast at sunset time - rendering f:lux useless.

    Any plans to update it in the close future?

    Thanks in advance for your reply!

    Best, Robert Domak


  • f.lux team



  • Thank you, it works perfectly! :)



  • @herf Sadly this update did not work for me. My f.lux also stopped working some time ago. I think it was before the W10 (64-bit) Anniversary update, but in any case, f.lux now does nothing at all. Running a Gateway with AMD and integrated graphics. Nothing special. I've tried all the usual tricks, driver upgrades, uninstall/reinstall and the like, but still no change. f.lux seems to think it's doing something, but nothing at all happens to the display. Really killing me :(



  • The latest version, v3.12, works fine on my Windows 10 without flickering ONLY when I UNCHECK "Use hotkeys (Alt-PgDn, Alt-PgUp, Alt-End)" checkbox under menu/Extras.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.