Installing f.lux on Ubuntu via Terminal



  • Just wanted to comment that the FAQ, at the very bottom, has an archived link on how to install f.lux on Ubuntu. However, you need to make sure that you are using the right file type and bit version. I've included it so you can just copy/paste it into the terminal. Maybe this could be added into the FAQ vs using an old/archived link that doesn't cover all the links available for Linux users?

    64-bit version with multiple monitor

    wget -c https://justgetflux.com/linux/xflux64.tgz
    $tar -xvzf xflux64.tgz
    $rm -rf xflux64.tgz
    $sudo cp xflux /usr/bin/
    $sudo chmod 755 /usr/bin/xflux

    32-bit build with support for multiple monitors

    wget -c https://justgetflux.com/linux/xflux-pre.tgz
    $tar -xvzf xflux-pre.tgz
    $rm -rf xflux-pre.tgz
    $sudo cp xflux /usr/bin/
    $sudo chmod 755 /usr/bin/xflux



  • doesn't work, no response at all on Kubuntu 14.04.4, 64-bit



  • This post is deleted!


  • @Dimitrie-Strătilă

    These instructions install it on your machine. To run xflux, do the following:

    Run flux with xflux command, you can also add it to your start up, But first you have to define your zipcode or latitude.Example :

    $xflux -l 33.55, -g 44.55

    To find your latitude and longitude, go to http://www.mapcoordinates.net/

    Or you can define zipcode -z instead of -l -g

    Now add it to your startup :

    System > Preferences > Sessions (or click the "System" icon and type "startup apps")

    Name : Xflux
    Command : xflux -l 33.55 -g 44.55 (DO NOT FORGET TO CHANGE the latitude or Zip!)
    Comment : F.lux , Better lighting For Your Computer



  • Yes, it's works, but be careful to remove the $ if you copy the line



  • Running 64 bit Mint 18. Install worked just fine. The instruction to run xflux was fine. Just one point, if you live in the western hemisphere don''t forget to put a - in front of your longitude. For example, -95.55 instead of 95.55. When I put in 95.55 it told me it was night and the screen dimmed down. At least I knew it worked. I imagine the same holds true for those in the southern hemisphere.

    Look forward to playing with this tool.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.