Can I set transition to be instant?



  • Hi,
    I'm using f.lux for 6 months and I love it. I need one feature though... during transition (I use the short one of 20 seconds) my computer slows down very much and mouse starts glitching. This is problem because when I work (and I usually do work at the evening when transition happens) it messes up the thing I am doing on the screen (eg. usually design/graphic related stuff where I use mouse intensively).

    So my question is can I have f.lux perform the transition instantly without slowing down my computer? Even 20 seconds of slow mouse/graphics responsiveness is a lot frustrating for me. There doesn't seem to be the settings for instant transition in the current version.

    Thanks



  • Alright, it's a great idea to update your drivers.
    If you aren't sure what hardware you have do the following:

    Click the start menu and type in
    dxdiag

    Choose yes (it won't take any longer, it checks once you open the program)

    This is DirectX Diagnostics and it's a GREAT way to see what video hardware you have.

    Go to the second tab from the left, and let me know the manufacturer and model of your video hardware.

    For Nvidia drivers, go to http://www.nvidia.com/
    For Intel, go to Intel.com and use this:
    http://www.intel.com/p/en_US/support/detect/

    That should be the driver update tool, although I'm not fond of it, it will help you if you're new to doing this.



  • I have similar problems if I am watching a movie. The movie judders for the 20 seconds it takes for f.lux to transition from day to night.
    It would be good if we could set manual durations for each.

    I would set the short transition to be instant, and extend the long one to be several hours long, so that the color temperature keeps dropping the longer I use the computer past a certain time.



  • @Guy said:

    and extend the long one to be several hours long, so that the color temperature keeps dropping the longer I use the computer past a certain time.

    The reason for the 1-hour transition is, it's the most realistic while also being the most reasonable in terms of consuming less computer resources than would be consumed with a several-hour transition time. Yes, the MOST realistic would be to constantly change color temperatures all day long from sunrise to sunset, but then imagine how many more people would be complaining about it slowing down their computer.



  • I'm not sure why extending it from say 1 hour to 3 would be any more resource-intensive.
    What I would like is that rather than 6500K to 3600K over the course of one hour, which is as low as I can stand to use and actually continue to get work done, it would be 6500K to 1200K over the course of three hours.
    So the transition might be 6500K to 4700K to 3000K to 1200K.

    I suspect that a non-linear transition would be perceptually smoother though, once you get below 3600K or so it starts to get very yellow/red very quickly.
    So you might have a four hour transition which hits 3600K after two hours, and then spend another two hours getting to 1200K



  • @Guy said:

    I'm not sure why extending it from say 1 hour to 3 would be any more resource-intensive.

    If the 20-second or 1-hour transition is already slowing someone's computer down during that transition, then they are definitely not going to enjoy or use a longer transition because it would slow their computer down for an even longer period of time.

    @Guy said:

    What I would like is that rather than 6500K to 3600K over the course of one hour, which is as low as I can stand to use and actually continue to get work done, it would be 6500K to 1200K over the course of three hours.
    So the transition might be 6500K to 4700K to 3000K to 1200K.

    I suspect that a non-linear transition would be perceptually smoother though, once you get below 3600K or so it starts to get very yellow/red very quickly.
    So you might have a four hour transition which hits 3600K after two hours, and then spend another two hours getting to 1200K

    You'd have to ask either Michael ("herf") or Lorna ("lorna") about this (they are the entire "f.lux team" - they're a husband and wife duo. hehe). All I know is, they have very good and logical reasons for why f.lux is the way it is. They will probably also say that if 3400K is too warm, then use "Disable for an hour".

    Personally, I don't allow f.lux to do anything automatically. I keep both 'Daytime' and 'At night" set to 6500K. When I'm ready to begin my routine of going to sleep and if I'm still going to be using my computer for another hour or two, then I will set f.lux to 1200K. I will also reduce my monitor's brightness down to its lowest setting and I also press Alt+Page Down one time (because otherwise certain things are too washed out - it might be just my monitor or something). I will also reduce my indoor lighting to be extremely dim and as warm as possible. It's a good thing I live alone. lol That would drive other people nuts who aren't ready to go to bed yet! "it's too dark in here. I can't see a damn thing. Geez dude".

    So yeah, until Michael and Lorna can make f.lux a bit more complex, we'll continue having to make do with what we have. They can only do so much though.



  • I think I've asked about this in the past, like a longer or deeper transition, and I'm positive that the mac version has something just like that, and I bet it works great!

    In fact, @TwoCables I think I remember you writing up something similar as a request too.



  • So what's the conclusion of this discussion now, can we expect this feature in the f.lux next version? It doesn't seem like a much to add in order to enable this feature (I am also working as software developer) so hopefully we should get "instant transition" soon.

    Regards



  • Have you done the following?

    @timpster said:
    Alright, it's a great idea to update your drivers.
    If you aren't sure what hardware you have do the following:

    Click the start menu and type in
    dxdiag

    Choose yes (it won't take any longer, it checks once you open the program)

    This is DirectX Diagnostics and it's a GREAT way to see what video hardware you have.

    Go to the second tab from the left, and let me know the manufacturer and model of your video hardware.

    For Nvidia drivers, go to http://www.nvidia.com/
    For Intel, go to Intel.com and use this:
    http://www.intel.com/p/en_US/support/detect/

    That should be the driver update tool, although I'm not fond of it, it will help you if you're new to doing this.



  • Yeah, the computer is not supposed to be slowing down, so an instant transition would be a band-aid solution. We would prefer to fix the problem so that your computer doesn't slow down during the transition. If you want to fix it, then please allow us to assist you because no one should have to deal with this problem.



  • I also noted higher CPU consumption during a transition. However it can be hastened by disabling it until sunrise / sunset, and after that break-point enabling it - so the transition runs immediately. F.lux is really very hardware time-consuming and I wonder why?



  • Alright, it's a great idea to update your drivers.
    If you aren't sure what hardware you have do the following:

    • --Another way to check video adapter
      Right click the desktop and choose "Screen Resolution"
      Then click the "Advanced Settings" near the right side when the window comes up.
      The next box that opens will tell you your video card information.

    Click the start menu and type in
    dxdiag

    Choose yes (it won't take any longer, it checks once you open the program)

    This is DirectX Diagnostics and it's a GREAT way to see what video hardware you have.

    Go to the second tab from the left, and let me know the manufacturer and model of your video hardware.

    For Nvidia drivers, go to http://www.nvidia.com/
    For Intel, go to Intel.com and use this:
    http://www.intel.com/p/en_US/support/detect/

    That should be the driver update tool, although I'm not fond of it, it will help you if you're new to doing this.



  • It's not necessary to write 3-times the same message. I do have an updated software for my video card. However, it is Intel 945 GM. And I don't have any lags, I just noted quite high CPU usage during transition. Also, now I found out that during displaying this forum my GPU works on 50%, and when I switch to another web page, GPU is at 0%. Weird things happens.



  • I was trying to get your hardware info. Now I know you have integrated onboard graphics which works from the CPU.

    I've run this program on a 500 MHz CPU on Linux mint 9 with the windows version of f.lux using Wine and it seemed to run very well.

    What CPU do you have and also what background processes do you have running?



  • Intel Core 2 Duo, 2x 1.8 GHz, model T5600 I think. How does this and other processes matter?



  • Because if I can run it just fine on inte..... oh shit. I used a GPU. Yep, just looked at it and the card is still in there. Now it was REALLY old, maybe a Nvidia FX 5500 or 5200, but still, that takes the load off the CPU.

    Now the real question is if I installed the drivers, I don't remember that part, but they were probably there. This matters because I thought it would run great on almost anything, but I think you have something in the background running that's eating up your CPU while f.lux is working, it REALLY shouldn't be this taxing, I'm going to reboot on onboard VGA soon to see what happens on my power CPU that idles at ~20 watts.

    EDIT: I can't do that because I'm running Xeon, which has absolutely (to my knowledge) NO support of any onboard graphics.



  • I have the same problem, and I'm positive it isn't my hardware/drivers. I have a 2600k and a 7970ghz (updated to the latest catalyst release driver) on Windows 10. When I play games, the transition always tanks my fps, even when I was on Windows 7. Additionally, my Win 8, broadwell i7, 970m laptop will have the fps tank if the transition goes during a gaming session. Can we please add an instant option, even if it's a bandaid, it would be greatly appreciated!?



  • I have an idea: set f.lux to 6500K before you're about to play a game. Or, exit f.lux. That way, you can play your game without worrying about it.


  • f.lux team

    We can do some more optimization here. In most of these cases, the video drivers are not showing us any slowness at all--it's showing up in another part of the system, so it's hard for us to auto-tune.

    We might be able to have a chunky transition as an option, but generally we're trying to adapt your eyes slowly (at the speed they adapt!) because otherwise your screen would suddenly turn really dark orange, not warm up a little bit.

    This slowdown seems to be "new" (in the last 2 years) since in the past these controls were extremely fast. As GPUs have started to mess with backlights and stuff like that I think the code underneath is getting a lot more complicated.



  • Hey Flux Team,

    I'd also like to report experiencing this issue and requesting an instant feature.

    I have my settings set to 60m transition unlike the OP, but experience the same symptoms on reboot/cold boot as it appears Flux performs the fast (20s) transition if you're past the mark on startup. I have the latest drivers installed and am using Windows 10. I'll detail my hardware below, but I have noticed something interesting during the transition phase: as soon as Flux loads and begins the transition I am seeing about a 20% spike in CPU usage for "Client Server Runtime Process" in my task manager. This ceases as soon as the transition has completed.

    I love your software, and would love to see it perform better. I'd like to request an instant option as the OP did. On top of that, I'd like to request an advanced option regarding the transition period on reboot, since the software seems to revert to 20s.

    Regardless of that, it might be nice to see a disable/enable toggle as the 1 hour period for use with photo applications seems like a rather short window; or perhaps an option to set your preferred amount of time for the auto enable. For example, if you are watching a movie and wish to disable for 2 hours? Or 3 hours if you intend to work from 5-8pm with a photo application before Flux kicks in.

    Anyway, as promised here are my system specs:
    Asus N550JX
    Windows 10 64 bit TS2/1511
    Intel HD Iris Pro/HD Graphics 4600: 15.33.38.64.4252 driver
    Allocating 256MB to dedicated graphics of 16GB.
    nVidia GTX 950M: 359.00 driver
    SanDisk SSD (not essentially relevant, but it's not a bottleneck issue)

    Also I am receiving these messages in Event Viewer during startup:
    The description for Event ID 0 from source igfxCUIService2.0.0.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    No idea if this will help in any way, but I hope it does. Thanks for your amazing product and please feel free to contact me if I could help in diagnosing the issue.

    --- PS. I double checked by setting System > Advanced System Settings > Hardware > Device Installation Settings to No; then uninstalling both display drivers with 'delete the driver software for this device' checked and then reinstalling. The issue persists...



  • I'm experiencing the same high CPU usage when the app is transitioning between one color temperature to the other. The task manager shows an average 30% CPU usage when the app gets activated or when the movie mode is changing the screen temperature.
    My complete specs:
    https://translate.google.com/translate?sl=es&tl=en&js=y&prev=_t&hl=en&ie=UTF-8&u=https%3A%2F%2Fwww.elcorteingles.es%2Felectronica%2FA16346308-portatil-acer-156-e5-573-56bl-intel-core-i5-5200u%2F&edit-text=&act=url
    http://www.acer.com/ac/es/ES/content/model/NX.MVHEB.014
    i5-5200U with Intel HD 5500 Integrated graphic card, 4 GB RAM 1600MHz, Samsung EVO 850 SSD.
    I'm using windows 10 64 bits and I'm using the latest drivers for all my parts and my bios is updated to the latest version to date.
    Edit:
    My system gets quite laggy and non responsive when the movie mode kicks in and until it finishes setting up the screen configuration. I don't really understand it because the CPU usage is not at 100% (just a bit more than 30%) but somehow I have to wait for the movie mode to get completely activated until I can keep on doing what I was doing, which usually delays my movie just a little bit.
    Edit 3 days later: I didn't have the latest Intel HD 5500 integrated graphic card driver, but even after updating it to the last version (15.40.18.4380) the problem still persists.
    .



  • Just wanted to add my setup to this thread. I'm also experiencing ~30% cpu usage when transitioning and the system lags so much its more like everything else is almost paused except for the mouse cursor while f.lux and my system judders through the transition.

    my specs are

    cpu: i3-6100
    mobo: MSI H110M Pro-VH
    memory: 16gb (2x8GB) DDR4 2133mhz Kingston Hyperx
    operating system: Windows 8.1 with the latest updates
    onboard graphics, intel HD 530 graphics.

    I believe the onboard graphics are updated to the latest version (20.19.15.4404 aka 15.40.18.4380) although Intel's Driver Update Utility and driver versioning practice makes it really challenging to tell. No matter what I do it always says this which makes it look like there is a newer version to update with. I have downloaded it using the utility and installed it, as well as downloading the latest beta directly from intel's website and installing that but the issue with f.lux remains. However I am confident the install of the latest version is running successfully as the same version shows in Device Manager and direct x diagnostics

    Thank you for your product and your efforts making it and supporting it. Even with the lag issue (I use movie mode a lot) I still value this software as I am a major night owl and as much as white screens have the blue light, I just can't stand 'night mode' in other softwares that turns the white of reddit or youtube black, for example.



  • O.K. this is starting to get a little crazy. How the hell can onboard graphics be bad enough (or drivers in that regard--I learned when I first installed them -- not sure where I got the idea for Intel graphics when I was young, just how much of a difference they make) to not change color like this?

    30% CPU shouldn't do ANYTHING to slow down the machine in a noticeable way. Why do I think that? I run folding@home on 6 out of 8 CPU threads (quad core) AND using up 1 full CPU thread (so 7 / 8) my GPU is full bore, 85-95% load there! CPU is around 85%, and GPU is 85+% load. My computer isn't noticeable slower. 30% should be nothing noticeable.



  • @Tungsten_smooth said:

    O.K. this is starting to get a little crazy. How the hell can onboard graphics be bad enough to not change color like this?

    not sure what you mean by this but I assume it's just a minor typo and you mean "bad enough to affect the performance or feel of the performance, of the computer". I don't have any issues with color changing - that I've noticed so far anyway, please don't give me something else to fixate on and obsess over :)

    Not sure if it is needed but I could record a video showing exactly what happens? Happy to do any or as much troubleshooting (save for reinstalling o/s) and trial and error testing if that helps.



  • @Casey-Ryback Do you have any older computers you could try? I've tried it on Nvidia FX 5500 and 5200, and they don't even use the FX name anymore, so that's REALLY old hardware, and even onboard Intel could run f.lux--I know because I remember uninstalling it when I first tried it. My old CRT wasn't setup right, and the mouse didn't match so it looked awful. Pinkish in tone.

    Onboard Intel graphics on even 5 - 6 year old CPUs should be able to handle this like it doesn't even exist. All it has to do is update the screen!

    I just can't stand 'night mode' in other softwares that turns the white of reddit or youtube black, for example.

    Try the "Darkroom mode" in f.lux. It's in the menu in the tray icons (by the clock). Right click the icon, and choose the option.



  • @Tungsten_smooth said:

    @Casey-Ryback Do you have any older computers you could try? I've tried it on Nvidia FX 5500 and 5200, and they don't even use the FX name anymore, so that's REALLY old hardware, and even onboard Intel could run f.lux--I know because I remember uninstalling it when I first tried it. My old CRT wasn't setup right, and the mouse didn't match so it looked awful. Pinkish in tone.

    Onboard Intel graphics on even 5 - 6 year old CPUs should be able to handle this like it doesn't even exist. All it has to do is update the screen!

    I just can't stand 'night mode' in other softwares that turns the white of reddit or youtube black, for example.

    Try the "Darkroom mode" in f.lux. It's in the menu in the tray icons (by the clock). Right click the icon, and choose the option.

    Haha, holy cow! I was not expect such a dramatic change from the Darkroom mode. I never thought to even click it before. I have to remember that

    I'm not sure this helps at all but I have installed f.lux on a Dell laptop with a Core 2 Duo cpu, onboard graphics and a Windows Vista sticker on it (so you know it's old) and it transitions without an issue. I have made sure to set it up as I have on my new computer and the issue does not happen there. I have a slightly older Toshiba laptop here (celeron processor, vista sticker, some variety of onboard graphics) but I only have linux on that currently. While the linux version doesn't have Movie Mode, I can seemingly simulate a transition by clicking Preview and that works without a stutter.

    So I dunno. It's not about raw performance, there's some weird conflict or bug with something common to my pc and the above posters' pc's and f.lux.



  • I would like to set my own transition speed. Fast is 20 sec, Slow is 60m. Rather, I want something like 5 sec.



  • @r3faat1 said:

    I would like to set my own transition speed. Fast is 20 sec, Slow is 60m. Rather, I want something like 5 sec.

    I was just talking to @lorna about this. :) So, hopefully the next version will provide far more customization options.



  • This post is deleted!


  • Made an account to request this feature as well. My CPU usage reaches 100% during transition and everything slows to a crawl.

    Four core Intel i5-6200U (2.30GHz)


  • f.lux team

    You can download v4 and choose "very fast" transitions from the Options menu.



  • I guess everyone knows it but those who use Windows 10 have a built in option that does the same as f.lux. It can be fount in settings -> display -> night light.
    I have been using it for a long time and it works fine.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.