Mouse cursor is much brighter on the primary screen (dual monitor setup)



  • For some reason, after installing Flux and diving into night mode, the mouse cursor appears much brighter on the primary monitor than it does on the secondary. It seems as if the cursor gets painted in full daylight mode on the primary monitor but in night mode on the secondary. The operating system is a genuine 64-bit Windows7, with latest patches applied.

    The only peculiar thing about my setup is that both monitors take their inputs from separate video devices -- primary from NVIDIA Quadro K600 and the secondary from integrated Intel HD 4600.

    Is this discrepancy in cursor coloring a bug or something that I can and should be able to configure myself?



  • I've never heard of this happening in a dual monitor setup, but when it happens in a single-monitor setup it's solved by a simple change to the Registry:

    You just navigate to HKEY_CURRENT_USER\Control Panel\Mouse and over in the right-hand pane, double-click "MouseTrails" and give it a value of 99. Then you log out of Windows and log back in.

    This enables Pointer Trails without actually resulting in any trails being rendered. Instead, it effectively forces the cursor to be rendered so that it is colored just like everything else. The only bad thing about this is, many video games are unable to show the cursor in the in-game menu with that set to 99.



  • It's probably caused by the two video outputs. F.lux probably only writes a profile or whatever for the first one, and doesn't change the others.

    Why do you use a monitor output per GPU?



  • @TwoCables Yes it's a software mouse, the magnifier does the same, and I have to close it when I want to run a fullscreen game, so it's an eaiser setup than the mouse trails for me, instead of adjusting that setting each time.



  • @TwoCables Thanks mate, that did the trick! I guess Flux just doesn't entirely support this "separate-monitor-separate-GPU" scenario.



  • @binary_fm said:

    @TwoCables Thanks mate, that did the trick! I guess Flux just doesn't entirely support this "separate-monitor-separate-GPU" scenario.

    Nice! You're very welcome.

    If you ever have an invisible mouse cursor in any in-game menus, then all you'll have to do is set '99' back to '0' and log out of Windows and log back in. You can even export two different .reg files: one for '99' and another for '0'. So, you'd set the value to either 99 or 0 and then you'd just right-click the Mouse key in the left-hand pane, choose Export, and put it somewhere you'll be comfortable with. Then you'd change the value to the other value (99 or 0) and then Export another.

    I put mine in a folder in My Documents and named them "mtOFF.reg" and "mtON.reg". That way, I just open the Start Menu, type "mtoff" or "mton" (for Mouse Trails OFF and Mouse Trails ON) and press Enter. Then I press Enter twice to say Yes and OK to the dialog boxes that come up and then I log out and back into Windows and I'm all set.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.