The screen goes black after flux opens



  • It seems like when xcode installs the app and than runs the app , the screen goes black(Of the app). But if we cancel the Running process, it works great



  • Same thing happened to me on my iPhone 6S on the latest iOS. I re-downloaded the Xcode project and tried again. It worked. Good luck, unique1o1!

    P.S. I also changed target build to iPhone and 9.1. Dunno if that helped me get a working version.



  • deleting from my iPad, cleaning project in Xcode and rebuilding fixed this for me.


  • f.lux team

    Anyone who gets this to happen twice in a row, please post details (Xcode version, iOS version, etc.) Want to fix it!



  • Happened to me twice in a row. Works great on my iPhone, but having trouble on iPad.

    Xcode 7.1.1 (7B1005)
    iPad mini 2 iOS 9.1
    Mac running 10.11.1


  • f.lux team

    This is non-retina? Wondering if the constraints are blowing up somewhere for that screen.



  • No, it's retina.



  • Update - I had not fully deleted the previous version and two f.lux apps were present on the iPhone 5s. One worked and one didn't. Deleted the broken one and everything works fine now. Also saw f.lux team mention below that the problems I experienced with the app were related to the app not finding it's location. Very happy to finally have f.lux.

    On an iphone 5s I first got the black screen. Then I rebuilt and reinstalled it and get f.lux to open - but it doesn't work. I press preview or darkroom and the display brightness/color does not change in any way. I press Disable and it greys out the settings, and press Enable to re-display the settings - but they don't seem to have any effect.

    It worked just fine on my iPhone 6s



  • Don't work on an iphone4 with iOS 7.1.2 Xcode 7.0.1
    install is ok but when running black screen and in Xcode trace

    2015-11-11 18:17:37.557 iflux[457:60b] -[UIApplication registerUserNotificationSettings:]: unrecognized selector sent to instance 0x14d91d50
    2015-11-11 18:17:37.569 iflux[457:60b] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[UIApplication registerUserNotificationSettings:]: unrecognized selector sent to instance 0x14d91d50'
    *** First throw call stack:
    (0x2fb8ef83 0x3a33fccf 0x2fb92917 0x2fb91203 0x2fae0768 0xf263b 0xf13d7 0x3241b587 0x3241aedb 0x3241556b 0x323b16e9 0x323b0851 0x32414ca9 0x349c9aed 0x349c96d7 0x2fb59a67 0x2fb59a03 0x2fb581d7 0x2fac2ebf 0x2fac2ca3 0x32413ed1 0x3240f14d 0xf07ef 0x3a84cab7)
    libc++abi.dylib: terminating with uncaught exception of type NSException
    (lldb)

    libsystem_kernel.dylib`__pthread_kill:
    0x3a9021e8 <+0>: mov r12, #328
    0x3a9021ec <+4>: svc #0x80
    -> 0x3a9021f0 <+8>: blo 0x3a902208 ; <+32>
    0x3a9021f4 <+12>: ldr r12, [pc, #0x4] ; <+24>
    0x3a9021f8 <+16>: ldr r12, [pc, r12]
    0x3a9021fc <+20>: b 0x3a902204 ; <+28>
    0x3a902200 <+24>: bicseq lr, r5, r0, lsr #28
    0x3a902204 <+28>: bx r12
    0x3a902208 <+32>: bx lr


  • f.lux team

    @peter2006 This is why it says iOS8+.


  • f.lux team

    Anyone running on iOS9 get a stack trace or an error log?

    thanks...



  • @herf Here you go. Is that what you're asking?

    1. Check dependencies
      Warning: Multiple build commands for output file /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app/iflux

    2. ProcessInfoPlistFile /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app/Info.plist Info.plist
      cd /Users/~/Documents/f.lux-xcode-master
      export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
      builtin-infoPlistUtility /Users/~/Documents/f.lux-xcode-master/Info.plist -genpkginfo /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app/PkgInfo -expandbuildsettings -format binary -platform iphoneos -requiredArchitecture arm64 -o /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app/Info.plist

    warning: User supplied UIDeviceFamily key in the Info.plist will be overwritten. Please use the build setting TARGETED_DEVICE_FAMILY and remove UIDeviceFamily from your Info.plist.

    1. Validate /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app
      cd /Users/~/Documents/f.lux-xcode-master
      export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin"
      export PRODUCT_TYPE=com.apple.product-type.application
      builtin-validationUtility /Users/~/Library/Developer/Xcode/DerivedData/iflux-gltbsggclfzfoqacthmajufhcgpg/Build/Products/Debug-iphoneos/iflux.app

    warning: All interface orientations must be supported unless the app requires full screen.



  • I have the same issue. I installed it on my own iPhone 6 running iOS 9.1 without a problem but when trying to install it on my friend's iPhone 6 running iOS 9.1, when running f.lux all I get is a dark screen. Also, XCode (7.1.1) then jumps to the following: http://i.imgur.com/WCayNx9.png

    I don't know where I can find an error log if at all?


  • f.lux team

    Wondering: did you happen to say 'no' to any prompts like location?

    This may mean the black screen is a crash and people are staying there because they're running in Xcode.



  • I didn't even get any prompts, right when I start the flux app, the screen turns dark and nothing happens.



  • The same here (iPad mini, iOS 9.1, Xcode 7.1.1, non-retina, MD528FD/A). Screen simply goes blank and Xcode displays the errors popsmisdeal posted.



  • I'm getting the black screen too. No prompts or anything.

    iPhone 6 Plus
    iOS 9.2 beta 3
    OS X El Capitan 10.11 Beta (15A278b)
    Xcode Version 7.2 beta (7C62)



  • I have this issue too on an iPad 3 (so Retina iPad) with iOS 9.1. I compiled with Xcode 7.1 on El Capitan. Just downloaded the project afresh, so no changes made. I never got any pop-ups on my iPad asking for any permissions. Flux is also not showing up in any of the permission views in Settings. Just first run it went black and never did anything besides showing the splash screen briefly. On my iPhone 5S with iOS 9.1 it works great by the way, so nice job!

    I couldn't properly debug the app, but when I used Xcode's Capture View Hierarchy on Device functionality, it opened a view where it said Thread 1: signal SIGSTOP. It was pointing at the line "0x2aa14f14 <+144>: mov r0, r5" in UIApplicationMain. I'm not sure if this line is easy for you to identify, so I'll post a subset of the total view:

    0x2aa14ef4 <+112>: bl 0x2ac4b3f4 ; _UIApplicationMainPreparations
    0x2aa14ef8 <+116>: movw r0, #0x6e34
    0x2aa14efc <+120>: movt r0, #0x1049
    0x2aa14f00 <+124>: movw r2, #0x167a
    0x2aa14f04 <+128>: movt r2, #0x110b
    0x2aa14f08 <+132>: add r0, pc
    0x2aa14f0a <+134>: add r2, pc
    0x2aa14f0c <+136>: ldr r1, [r0]
    0x2aa14f0e <+138>: ldr r0, [r2]
    0x2aa14f10 <+140>: blx 0x2b31482c ; symbol stub for: ceilf$shim
    0x2aa14f14 <+144>: mov r0, r5 <----------- SIGSTOP signal pointing at this line.
    0x2aa14f16 <+146>: blx 0x2b31487c ; symbol stub for: objc_getProperty$shim
    0x2aa14f1a <+150>: mov r0, r4
    0x2aa14f1c <+152>: blx 0x2b31487c ; symbol stub for: objc_getProperty$shim
    0x2aa14f20 <+156>: movs r0, #0x0
    0x2aa14f22 <+158>: pop.w {r8, r10}
    0x2aa14f26 <+162>: pop {r4, r5, r6, r7, pc}
    0x2aa14f28 <+164>: movw r0, #0xe64
    0x2aa14f2c <+168>: movt r0, #0x110b
    0x2aa14f30 <+172>: movw r1, #0x3776
    0x2aa14f34 <+176>: movt r1, #0xeae
    0x2aa14f38 <+180>: add r0, pc
    0x2aa14f3a <+182>: add r1, pc
    0x2aa14f3c <+184>: blx 0x2b315dac ; symbol stub for: -[UILayoutGuide setIdentifier:]

    I hope that helps :) If you need any more info, please ask.



  • Worked great on my iPad Mini, but when I installed in my iPhone 5 or my wife's iPhone 5s, I got the same "blank screen on launch". No prompts at all — it briefly shows the Flux splash screen, then goes to black.

    Fortunately I can just press the Home button to get back to normal function of the iPhone. But no-go on F.lux itself.



  • After launching f.lux I get a black screen

    xcode: Version 7.1.1 (7B1005)
    iphone 6 plus: 9.1 (13b143)
    Macbook air: 10.11.1 (15B42)



  • Black screen after brief splash screen as well. No prompts either, but home button returns to home screen.

    iPhone 5 and iPad Air 2
    iOS 9.1 (13B143)
    Xcode Version 7.1 (7B91b)
    Macbook Pro mid 2012
    OSX Yosemite 10.10.5 (14F1021)



  • On an iPad Air (1) with Xcode 7.1.1 (7B1005)/IOS 9.1 (13B143)/OSX 10.11.1

    .I built and reinstalled it and get f.lux to open - but it doesn't work. I press preview or darkroom and the display brightness/color does not change in any way. I press Disable and it greys out the settings, and press Enable to re-display the settings - but they don't seem to have any effect

    2015-11-12 07:36:55.081 iflux[642:114264] Unable to simultaneously satisfy constraints.
    Probably at least one of the constraints in the following list is one you don't want.
    Try this:
    (1) look at each constraint and try to figure out which you don't expect;
    (2) find the code that added the unwanted constraint or constraints and fix it.
    (
    "<NSLayoutConstraint:0x154545530 V:|-(20)-[UIInputSetContainerView:0x154519c60] (Names: '|':UITextEffectsWindow:0x15453edb0 )>",
    "<NSLayoutConstraint:0x154602540 'UIInputWindowController-top' V:|-(0)-[UIInputSetContainerView:0x154519c60] (Names: '|':UITextEffectsWindow:0x15453edb0 )>"
    )

    Will attempt to recover by breaking constraint
    <NSLayoutConstraint:0x154545530 V:|-(20)-[UIInputSetContainerView:0x154519c60] (Names: '|':UITextEffectsWindow:0x15453edb0 )>

    Make a symbolic breakpoint at UIViewAlertForUnsatisfiableConstraints to catch this in the debugger.
    The methods in the UIConstraintBasedLayoutDebugging category on UIView listed in <UIKit/UIView.h> may also be helpful.
    2015-11-12 07:36:55.097 iflux[642:114264] Got display 55017000
    2015-11-12 07:36:55.097 iflux[642:114264] Got table with 1003
    2015-11-12 07:36:55.097 iflux[642:114264] 0.000000 0.000000 1024.000000 768.000000
    2015-11-12 07:36:55.215 iflux[642:114264] f.lux setup
    2015-11-12 07:36:55.659 iflux[642:114264] <CATransformLayer: 0x154666050> - changing property masksToBounds in transform-only layer, will have no effect
    2015-11-12 07:36:55.660 iflux[642:114264] <CATransformLayer: 0x154664270> - changing property masksToBounds in transform-only layer, will have no effect
    2015-11-12 07:36:55.661 iflux[642:114264] <CATransformLayer: 0x15467e090> - changing property masksToBounds in transform-only layer, will have no effect


  • f.lux team

    @peter2006 this happens when your location isn't found.
    we should add an error..



  • @herf
    ok i enabled location and notification It's OK thanks but i dislike the location obligatory



  • So, on iOS 9.1 with an iPhone 6, I also only get a black screen after the loading screen, but:

    In the App settings, I can only set the permissions for background updates. It doesn´t show up in privacy > location, nor in the notifications area of the settings. Deployment Target in xCode 7.1.1 was set to 9.1 and iPhone, and permissions for my "developer" profile were given in profiles.



  • iPhone 6 (iOS 9.1 build 13B143), trying to install via Xcode (7.1.1 build 7B1005).
    After pressing Cmd+R it starts running on the device, but on the Xcode it opens main.m and highlights the line
    return UIApplicationMain(argc, argv, nil, NSStringFromClass([AppDelegate class]));

    It also shows something I think that is the log:
    2015-11-12 21:37:03.895 iflux[10193:4804126] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'Could not load NIB in bundle: 'NSBundle </var/mobile/Containers/Bundle/Application/F14BBACA-DBB9-482F-B560-083261E86C4A/iflux.app> (loaded)' with name 'LaunchScreen''
    *** First throw call stack:
    (0x185440f48 0x199ff3f80 0x185440e90 0x18ae98c88 0x18ae9b408 0x18ac7ce18 0x18aa48fc4 0x18ac7bcb8 0x18ac78f50 0x18f25f7c4 0x18f25fb44 0x1853f8544 0x1853f7fd8 0x1853f5cd8 0x185324ca0 0x18aa421c8 0x18aa3cffc 0x1000ecaf8 0x19a8428b8)
    libc++abi.dylib: terminating with uncaught exception of type NSException
    (lldb)

    Sorry, but I'm not very keen in programming. What's funny is that yesterday I have successfully installed f.lux on my iPad 4 running the same build of iOS via the same Xcode version.



  • I have an iPhone 5 running 9.1 and I also get the black screen after launch. By mistake I chose not to let it use my location, but now there is no option to allow it in Settings. And deleting, recompile and reinstall doesn't help unfortunately.

    Besides that, thank you f.lux team for letting iOS users use the app! My eyes are looking forward to it. :-)



  • I've got the exact same issue here. It works great on my iPhone 5S running iOS 9.1, but it fails to open (it shows the splash screen and goes to the black screen already mentioned) on my iPad 3 running iOS 9.1 as well. I didn't fail to give permission to anything or to trust my AppleID profile on Settings.

    I compiled it and sideloaded it on XCode 7.1 running on OS X 10.11.1 so, as you can see, I've got everything updated to the latest versions…

    Fortunately, I don't use my iPad much at night anyway (in fact, it's so heavy that I haven't used it much anymore since I've bought my iPhone), but it'd be nice to have f.lux on all my devices. I really suspect that exposure to backlights has affected my sleeping patterns lately, and f.lux, if it actually works, will be a godsend.



  • I managed to successfully load this app to my iPad 3 (9.1) on my first try. No pop up requests for location or notifications were made, they were turned on automatically. Also, no prompt for security clearance to make the app open, but I knew to manually accept my profile.

    Unfortunately, when I attempted to load it to my iPhone 6 (9.1) Xcode threw its toys out of the pram. It crashed with a multitude of errors on two separate installs and I had to delete and re-download the files from here, twice. On my third go I got the app onto my iPhone, but after the splash page it went black. I could exit the app, no problem. I have deleted it and tried twice more. Each time I am left with the black screen and no explanation. I am looking forward to the fix.



  • Reset everything, started from scratch from a clean download from this site... sideloaded onto my iPhone 6 again. Still no joy. :s



  • Oh, and using Xcode 7.1.1 (7B1005), downloaded today. That is three times I've successfully side loaded the app onto my phone, only for it to go black after the splash screen. I really am keen to get the app working you see!



  • Device: iPhone 5C
    Firmware: iOS 9.1 (13B143)
    Computer: MacBook Air El Capitan Version 10.11.1
    Xcode: Version 7.1.1 (7B1005)

    Tried 3 times but still get the black screen. No chance to allow/deny prompts. The developer profile is trusted. There is no options in the App Settings to allow location or notifications.

    I successfully loaded f.lux on my iPhone 6 Plus and friend's iPhone 5S, both running iOS 9.1, using the same computer and version of Xcode. But the my friend's iPhone 5C can't get past the black screen.



  • +1 I get this on Xcode 7.1.1 on an old iPhone 5S running iOS 9.1 built on OSX El Capitan 10.11.1



  • I was finally able to successfully install on my iphone 6 plus.

    here's what I did:

    Product-->Clean
    Command+R and it installed correctly.
    I hope this helps.



  • That worked for me too: Product-> Clean
    Command+R



  • I was seeing this same behavior on iPhone 6, iOS 9.2 Beta 3 and Xcode Beta 7.2. I had to do the Product > Clean, then the build worked perfectly!



  • The Product> Clean trick worked for me too. Now running on both my devices.

    It is not running well, though, and during the evening it would not accept my choice of colour temperature... had to disable :(

    Do you think we will still get any fixes for this, or is it dead in the water now? Such a pity

    EDIT: That is the broken 'bedtime mode' kicking in. 'Set to dawn' is the advised fix



  • I loaded f.lux on my iphone 6 running iOS 9.1 to test and ensure that this worked before I un-jailbroke my iPad to update it to 9.1. Worked flawlessly on iPhone, but experienced the black screen after install issue when loading on iPad.

    tl;dr - Doing product -> clean (⇧⌘k) then rebuilding (⌘r) fixed the issue.



  • SOLUTION:
    I had this experience today, I installed iFlux on my old iPhone 6, then switched to my new iPhone 6s and installed it receiving the same issue posted.
    After verifying the install, reinstalling, trying an alternate profile and verifying the location services I did the following.

    Create a unique copy of iFlux XCode code project for the new device and go through the process again.

    This fixed my problem.

    So the 4 things that need to be verified for the install to work properly.

    • ensure that you are using iOS version 9.1 (or later)
    • trust the application installer
    • enable location services
    • Create a unique copy of the iFlux XCode code project for each device you plan to installing it on. Then use that code project instance to install on the new device ... note: you may need to use unique names for each version (I did this by default), I may have also cleaned and rebuilt the solution


  • @alexkrasn

    Fixed it for me too. Created a new xcode project for my ipad instead of using the same one as my iphone and gave it a different bundle identifier.



  • @supercat said:

    deleting from my iPad, cleaning project in Xcode and rebuilding fixed this for me.

    Me too!

    1. delete app form iPhone.
    2. cleaning Xcode
    3. rebuild and install to iPhone again.


  • Product->Clean worked for me also. 6S+ 9.3.3



  • Think this topics


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.