f.lux causes major stuttering in games every 1 second



  • When f.lux is in daytime mode, games (Fallout, Grid, etc..) suffer a 100ms freeze every 1 second. This makes the game unplayable.

    I thought it was a VSync problem, but none of the VSync options in the nVidia control panel helped. Plus it also happens in Windowed mode, so it cannot be a VSync issue.
    Tried multiple nVidia driver versions as well.

    After f.lux goes into nighttime mode, or if I exit f.lux from the system tray, the stutter completely goes away.

    I tried disabling f.lux in its menu but that didn't help, I have to completely close f.lux to recover.

    PC specs:
    nVidia GTX970
    Core i7 4770
    Win10 64bit
    Intel Mainboard
    8GB RAM
    SSD ( Drive c: )

    ps. here's another person who experienced the same thing:
    http://www.tomshardware.com/answers/id-1715649/games-stuttering.html


  • f.lux team

    Does disabling DDC/CI on your monitor help?

    NVIDIA drivers seem early for Windows 10.

    Our Windows 7-8 machines do not do this, but we have not upgraded yet.



  • Cant find those settings in the Monitor device properties or the in the Monitor settings itself, will need to google to find out how to do that.

    I believe it was happening in Win8.1 as well, but anyway, what is flux doing once a second?
    Seems like its on a 1000ms timer and is polling the display driver for color info every second.
    Perhaps we could have an option to increase this timer to 60000ms (1 minute)

    Monitor is a Samsung S27A950D 120hz but set to 60hz using DVI cable.



  • What might be happening is something else is trying to override f.lux and f.lux pushes back with daytime color.

    Are you sure you don't have any apps that dim the screen or color? You don't have to name them but if you do they are probably interfering.

    Also check Nvidia control panel and reset the color settings and choose "let other programs manage color".


  • f.lux team

    The trouble with polling is you can't predict the future.

    So for instance, a rather huge number of Intel GPUs forget all their color settings on suspend. And on login, sometimes a color profile is reset multiple times.

    What you don't want in those circumstances is to be waiting around for 49 seconds with a bright screen, because you've decided to poll once a minute instead of once a second. It really sucks, because we've tried it.

    However, in some cases we could do a lot better - like we shouldn't poll very much during the day and stuff like that.



  • Just to confirm: I had this exact issue last night playing Torchlight II under Windows 10 with Vsync on. Took me a while to figure out the stuttering (once a second) was caused by f.lux. Once I deactivated it the stutter went away and the game ran smoothly at 60 fps. Guess for now I'll have to adjust my display's colour management directly for a warmer temperature when gaming at night.

    Cheers

    Nate



  • I have the exact same problem. Asus UX305. Intel M-5Y10. 8gb. SSD.

    Happens on both Win 8.1 and Win 10.

    No other programs installed. Took me a loooong time to figure out F.lux was the culprit. Will look around and let you know if I find a solution.


  • f.lux team

    "Safe Mode" tries to do the best thing for this case.



  • Took me awhile to figure out that the stuttering was caused by f.lux. What does "Safe mode" do? It helps with the stuttering. But does it mean that it just reduces the rate of whatever f.lux does that causes a stutter?



  • Yep, I have the same problem. Exiting f.lux is the only fix. I have Windows 7 too.

    Is this going to be fixed in a future release? It's inconvenient to have to Alt+Tab out of a game (or exit a game in some instances) just to either switch f.lux to Safe Mode or exit it altogether. I almost never remember to do so before launching a game because I have years and years of a habit of simply launching a game without having to do anything else first.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.