Flickering when computer resumes from hibernation



  • Hey,

    I searched for this because I assumed it might be a common problem, but I couldn't find anything so I'm sorry if this has already been asked. I'm currently using a Sony Vaio Flip running Windows 8.1. Every night I hibernate my computer, when f.lux is in night mode, and when I resume the computer in the morning, the screen is flickering. It seems like it's flickering between the night and day modes of f.lux. I have to exit and reopen f.lux every morning to fix this. The touch screen on the computer is disabled, if that matters. Is there something I can do to fix this?



  • ummm I have this problem too. I have a Asus Transformer Chi T300. Why hasn't anyone responded to this yet??



  • I have the exact problem on the the very same machine, did you find any soln for this? (Sony Vaio Flip running Windows 8.x )


  • f.lux team

    Hey peoples, sorry for not responding earlier. See if you have an update to your video drivers and if not please post back with your Windows version and GPU / driver version. There are some flickering problems, usually they're in the drivers, but we like to keep track.



  • Hey, I have this same problem with a Vaio Pro 13. Using Windows 8.1 but the problem persisted back when I had Windows 8 as well. Every time I get out of hibernation, the screen flickers for 20 sec (time it takes to adjust). Using Intel HD Graphics 4400 with driver version 10.18.10.3355. Let me know if this can be fixed. Thanks!



  • Mine is not about waking, but rather when f.lux tries to do it's thing, my screen begins flickering between regular and the setting f.lux is trying to set. if it tell f.lux to temporarily suspend what's it's doing, problem disappears. I am running a brand new dell 15' 2 in 1 running version 6 skylark (i7) and the on board intel graphics fully updated: HD Graphics 530 driver: 20.19.15.4300.



  • [SOLUTION]

    At least, for me.
    The next few terms might be a bit off, but my system is in Dutch, so I had to translate it to English.
    Open VAIO Control Center, go to the "Image Quality" (I guess) --> "Color mode" --> "Don't apply color mode"

    In short, the problem is that Vaio Control Center is fighting with F.lux to change your color profile.

    • Jeroen

    EDIT The faq apparently already mentions this here.



  • I have this happen to me as well, and it's incredibly frustrating. Everything would seem to work fine, but whenever the display comes out of sleep, flux would go bonkers. Closing flux and reopening it wouldn't help.

    In my case I have noticed sometimes a "ghost" secondary monitor would appear up on my Display Settings, usually after my (real) display goes into sleep mode. I believe this is has to do with Intel WiDi technology, as the secondary display would sometimes be called just "Virtual Display" and other "Intel Wi-Di".

    By default this fake secondary display is setup to extended the desktop, which in my case would cause flux to either do nothing or flicker the screen as this thread describes.

    I fixed this by right-clicking my desktop, then "Graphics Options" (this is added by Intel's drivers), then "Output to", and selecting just "Digital Display". This especially disables WiDi. As soon as I did this, the flickering stopped and my display immediately went back to the proper color temperature.

    In case it matters, my system is a custom build (ASUS Z170-A motherboard, Intel HD Graphics 530) running Windows 10 Pro 64-bit.

    Hope this helps.



  • @sparkline Thanks , solved the issue for me also. I could donate to you for this suggestion :) I gave up using fLux but now restart to use it since now I have no problem with that. Means lots to me, thanks again.

    BTW the terms are just what your saying.



  • @omerfaruk no problem, and no donation needed ;-) .
    Just posted it here hoping some more people could benefit from it. It was the first place my google-fu brought me, and no solution was yet provided.


Log in to reply
 

Looks like your connection to f.lux forum was lost, please wait while we try to reconnect.